summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-06 22:25:21 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-06 22:25:21 +0200
commit56203284b626cfefac355ecc10ec23191d80eabd (patch)
tree4ca812fee3099f59ad2093a389e8c8df52997fae
parentf5d4a138a7937f6a9ff4dd1cca693935322977ba (diff)
downloadpatches-56203284b626cfefac355ecc10ec23191d80eabd.tar
patches-56203284b626cfefac355ecc10ec23191d80eabd.tar.gz
gnu: Add libvisio.
* gnu/packages/libreoffice.scm (libvisio): New variable.
-rw-r--r--gnu/packages/libreoffice.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 98d646cddd..fb308603c6 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -387,3 +387,37 @@ Microsoft Publisher documents of all versions.")
Aldus/Adobe PageMaker documents. Currently it only understands documents
created by PageMaker version 6.x and 7.")
(license mpl2.0)))
+
+(define-public libvisio
+ (package
+ (name "libvisio")
+ ;; FIXME: The newer version 0.1.1 fails its tests.
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
+ name "-" version ".tar.xz"))
+ (sha256 (base32
+ "0vvd2wyp4rw6s9xnj1dc9vgdpfvm45gnb5b9hhzif0fdnx4iskqf"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("cppunit" ,cppunit)
+ ("doxygen" ,doxygen)
+ ("gperf" ,gperf)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("boost" ,boost)
+ ("icu4c" ,icu4c)
+ ("librevenge" ,librevenge)
+ ("libxml2" ,libxml2)))
+ ;; FIXME: Not needed any more for newer version 0.1.1.
+ (arguments
+ ;; avoid triggering a build failure due to warnings
+ `(#:configure-flags '("--disable-werror")))
+ (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libvisio")
+ (synopsis "Library for parsing the Microsoft Visio format")
+ (description "Libvisio is a library that parses the file format of
+Microsoft Visio documents of all versions.")
+ (license mpl2.0)))