summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-29 21:32:55 -0400
committerLeo Famulari <leo@famulari.name>2016-10-29 21:43:24 -0400
commit329b4b3b69380b232129fcd65f9f41c195aa336d (patch)
tree8281a7eb6157c2d70af1e0ce6f94df7c7055de5e
parentbae187105907a1fe94fb2f6a661920299b9cd877 (diff)
downloadpatches-329b4b3b69380b232129fcd65f9f41c195aa336d.tar
patches-329b4b3b69380b232129fcd65f9f41c195aa336d.tar.gz
gnu: Add python-pyev.
* gnu/packages/python.scm (python-pyev, python2-pyev): New variables.
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 55efd4d4c0..dcc72b33d2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11376,3 +11376,36 @@ useful as a validator for JSON data.")
(description
"This package adds SQLAlchemy support to your Flask application.")
(license license:bsd-3)))
+
+(define-public python-pyev
+ (package
+ (name "python-pyev")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyev" version))
+ (sha256
+ (base32
+ "0rf603lc0s6zpa1nb25vhd8g4y337wg2wyz56i0agsdh7jchl0sx"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libev (string-append (assoc-ref inputs "libev")
+ "/lib/libev.so.4")))
+ (substitute* "setup.py"
+ (("libev_dll_name = find_library\\(\\\"ev\\\"\\)")
+ (string-append "libev_dll_name = \"" libev "\"")))))))))
+ (inputs
+ `(("libev" ,libev)))
+ (home-page "http://pythonhosted.org/pyev/")
+ (synopsis "Python libev interface")
+ (description "Pyev provides a Python interface to libev.")
+ (license license:gpl3)))
+
+(define-public python2-pyev
+ (package-with-python2 python-pyev))