summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-03-27 23:22:30 -0400
committerLudovic Courtès <ludo@gnu.org>2019-03-30 15:19:31 +0100
commit14c297fde12f2dd401abadd3896b72ebbf5d571b (patch)
treed078d9512f5d889ed7bcb60d51ba27a3469f4002
parent29a9eb9e1a958414aae902dbb96fe01e90d2de89 (diff)
downloadpatches-14c297fde12f2dd401abadd3896b72ebbf5d571b.tar
patches-14c297fde12f2dd401abadd3896b72ebbf5d571b.tar.gz
gnu: gnome-online-accounts: Split off 'lib' output.
gnu/packages/gnome.scm (gnome-online-accounts)[outputs]: Add 'lib'. [arguments]: Set the 'libdir' path to the 'out' output, and add a phase to ensure that libgoa gets installed in the 'lib' output. (evolution-data-server, gfbgraph, gnome-calendar, gnome-control-center, gnome-todo, libgdata, libzapojit): Use the 'lib' output of gnome-online-accounts. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm29
1 files changed, 23 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 060379aba9..9222f99003 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -389,7 +389,7 @@ formats like PNG, SVG, PDF and EPS.")
("libsoup" ,libsoup)))
(propagated-inputs
`(("gcr" ,gcr)
- ("gnome-online-accounts" ,gnome-online-accounts)
+ ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
("liboauth" ,liboauth)
("libxml2" ,libxml2)))
(home-page "https://wiki.gnome.org/Projects/libgdata")
@@ -4941,7 +4941,23 @@ window manager.")
(sha256
(base32
"1l8p1ghknmkmjpnpl7jr53j66qbzpikickzbmrz0aczyhq6pdy29"))))
+ (outputs '("out" "lib"))
(build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--libdir=" (assoc-ref %outputs "out") "/lib"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-libgoa-output
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((lib (assoc-ref outputs "lib")))
+ (substitute* '("src/goa/Makefile.in" "src/goa/goa-1.0.pc.in")
+ (("@prefix@") lib)
+ (("@exec_prefix@") lib)
+ (("@libdir@") (string-append lib "/lib"))
+ (("@includedir@") (string-append lib "/include"))
+ (("@datadir@") (string-append lib "/share")))
+ #t))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
("gobject-introspection" ,gobject-introspection)
@@ -5038,7 +5054,7 @@ Exchange, Last.fm, IMAP/SMTP, Jabber, SIP and Kerberos.")
(inputs
`(("bdb" ,bdb)
("gcr" ,gcr)
- ("gnome-online-accounts" ,gnome-online-accounts)
+ ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
("json-glib" ,json-glib)
("libgweather" ,libgweather)
("mit-krb5" ,mit-krb5)
@@ -5631,6 +5647,7 @@ devices using the GNOME desktop.")
("gnome-bluetooth" ,gnome-bluetooth)
("gnome-desktop" ,gnome-desktop)
("gnome-online-accounts" ,gnome-online-accounts)
+ ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
("gnome-settings-daemon" ,gnome-settings-daemon)
("grilo" ,grilo)
("ibus" ,ibus)
@@ -6300,7 +6317,7 @@ library.")
("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(inputs
- `(("gnome-online-accounts" ,gnome-online-accounts)
+ `(("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
("json-glib" ,json-glib)
("rest" ,rest)))
(home-page "https://wiki.gnome.org/Projects/Zapojit")
@@ -6373,7 +6390,7 @@ desktop. It supports world clock, stop watch, alarms, and count down timer.")
("pkg-config" ,pkg-config)))
(inputs
`(("evolution-data-server" ,evolution-data-server)
- ("gnome-online-accounts" ,gnome-online-accounts)
+ ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
(home-page "https://wiki.gnome.org/Apps/Calendar")
(synopsis "GNOME's calendar application")
@@ -6425,7 +6442,7 @@ desktop. It supports multiple calendars, month, week and year view.")
("libpeas" ,libpeas)
("python-pygobject" ,python-pygobject)
("evolution-data-server" ,evolution-data-server)
- ("gnome-online-accounts" ,gnome-online-accounts)
+ ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
(home-page "https://wiki.gnome.org/Apps/Todo")
(synopsis "GNOME's ToDo Application")
@@ -6754,7 +6771,7 @@ compiled.")
("gobject-introspection" ,gobject-introspection)))
(inputs
`(("json-glib" ,json-glib)
- ("gnome-online-accounts" ,gnome-online-accounts)
+ ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
("rest" ,rest)))
(synopsis "GLib/GObject wrapper for the Facebook API")
(description "This library allows you to use the Facebook API from