summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-16 04:39:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-16 15:45:34 +0100
commite76cbdcd90e603d98f9d074aa2ee0788c65d97df (patch)
treec3104ed2035e314ed0d967ed1b5ab9c3df601273
parent066c21cda4a9893a0cc8398d1a4d3f9f1ac1dfbb (diff)
downloadpatches-e76cbdcd90e603d98f9d074aa2ee0788c65d97df.tar
patches-e76cbdcd90e603d98f9d074aa2ee0788c65d97df.tar.gz
gnu: beets: Fix build with newer Werkzeug.
* gnu/packages/patches/beets-werkzeug-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/music.scm (beets)[source](patches): New field.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/music.scm1
-rw-r--r--gnu/packages/patches/beets-werkzeug-compat.patch18
3 files changed, 20 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 1dd7e0a6a8..5cde920c8c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -756,6 +756,7 @@ dist_patch_DATA = \
%D%/packages/patches/bash-completion-directories.patch \
%D%/packages/patches/bastet-change-source-of-unordered_set.patch \
%D%/packages/patches/bazaar-CVE-2017-14176.patch \
+ %D%/packages/patches/beets-werkzeug-compat.patch \
%D%/packages/patches/beignet-correct-file-names.patch \
%D%/packages/patches/benchmark-unbundle-googletest.patch \
%D%/packages/patches/biber-fix-encoding-write.patch \
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index f6585f60d4..fd9cd6c30f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2941,6 +2941,7 @@ Songs can be searched by artist, name or even by a part of the song text.")
(source (origin
(method url-fetch)
(uri (pypi-uri "beets" version))
+ (patches (search-patches "beets-werkzeug-compat.patch"))
(sha256
(base32
"0m40rjimvfgy1dv04p8f8d5dvi2855v4ix99a9xr900cmcn476yj"))))
diff --git a/gnu/packages/patches/beets-werkzeug-compat.patch b/gnu/packages/patches/beets-werkzeug-compat.patch
new file mode 100644
index 0000000000..1a91c3a3f9
--- /dev/null
+++ b/gnu/packages/patches/beets-werkzeug-compat.patch
@@ -0,0 +1,18 @@
+Be compatible with python-werkzeug 1.0.0.
+
+Taken from upstream:
+https://github.com/beetbox/beets/commit/d43d54e21cde97f57f19486925ab56b419254cc8
+
+diff --git a/beetsplug/web/__init__.py b/beetsplug/web/__init__.py
+index f53fb3a954..21ff5d94ed 100644
+--- a/beetsplug/web/__init__.py
++++ b/beetsplug/web/__init__.py
+@@ -169,7 +169,7 @@ def to_python(self, value):
+ return ids
+
+ def to_url(self, value):
+- return ','.join(value)
++ return ','.join(str(v) for v in value)
+
+
+ class QueryConverter(PathConverter):