summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-16 14:23:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-16 15:45:38 +0100
commite26e084fbb33608379d124030d8f9413fcb00a16 (patch)
treef1002c039e6f9461db8b033b935842866e28adf4
parent386d2fd130dd557a81620e8409e05e6be7c7507a (diff)
downloadpatches-e26e084fbb33608379d124030d8f9413fcb00a16.tar
patches-e26e084fbb33608379d124030d8f9413fcb00a16.tar.gz
gnu: python-zope-security: Update to 5.1.0.
* gnu/packages/python-web.scm (python-zope-security): Update to 5.1.0. [native-inputs]: Remove PYTHON-SIX. Move PYTHON-ZOPE-COMPONENT and PYTHON-ZOPE-LOCATION ... [propagated-inputs]: ... here. Add PYTHON-ZOPE-INTERFACE. (python2-zope-security)[propagated-inputs]: Remove.
-rw-r--r--gnu/packages/python-web.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6ff5482612..b02ffd5f58 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1236,26 +1236,26 @@ Zope3, which are are special objects that have a structural location.")
(define-public python-zope-security
(package
(name "python-zope-security")
- (version "4.0.3")
+ (version "5.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "zope.security" version))
(sha256
(base32
- "14zmf684amc0x32kq05yxnhfqd1cmyhafkw05gn81rn90zjv6ssy"))))
+ "1npfrgnm202v48wavpwn3450dsn7az12lfww95vbhxyjl11f14yb"))))
(build-system python-build-system)
(arguments
'(#:tests? #f)) ; FIXME: Tests can't find zope.testrunner.
(propagated-inputs
- `(("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
+ `(("python-zope-component" ,python-zope-component)
+ ("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
+ ("python-zope-interface" ,python-zope-interface)
+ ("python-zope-location" ,python-zope-location)
("python-zope-proxy" ,python-zope-proxy)
("python-zope-schema" ,python-zope-schema)))
(native-inputs
- `(("python-six" ,python-six)
- ("python-zope-component" ,python-zope-component)
- ("python-zope-configuration" ,python-zope-configuration)
- ("python-zope-location" ,python-zope-location)
+ `(("python-zope-configuration" ,python-zope-configuration)
("python-zope-testrunner" ,python-zope-testrunner)
("python-zope-testing" ,python-zope-testing)))
(home-page "https://pypi.org/project/zope.security/")
@@ -1265,13 +1265,7 @@ security policies on Python objects.")
(license license:zpl2.1)))
(define-public python2-zope-security
- (let ((zope-security (package-with-python2 python-zope-security)))
- (package (inherit zope-security)
- (propagated-inputs
- `(("python2-zope-testrunner" ,python2-zope-testrunner)
- ,@(alist-delete
- "python-zope-testrunner"
- (package-propagated-inputs zope-security)))))))
+ (package-with-python2 python-zope-security))
(define-public python-zope-component
(package