summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-16 03:43:25 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-16 15:45:33 +0100
commit8f29817ed523dd4e5dbd459ecb94dbd1cab6a4fc (patch)
tree6dfe7c05d99d67f14a1556685260e1f25b570dc0
parent33901ed8c0a85e9b0badbc7ea042d310bdfac970 (diff)
downloadpatches-8f29817ed523dd4e5dbd459ecb94dbd1cab6a4fc.tar
patches-8f29817ed523dd4e5dbd459ecb94dbd1cab6a4fc.tar.gz
gnu: python-flask-wtf: Update to 0.14.3.
* gnu/packages/python-web.scm (python-flask-wtf): Update to 0.14.3. [arguments]: Remove obsolete phase. Override check phase. [native-inputs]: Remove PYTHON-NOSE. Add PYTHON-PYTEST.
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b87764b907..6d4204bad0 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1770,31 +1770,29 @@ presume or force a developer to use a particular tool or library.")
(define-public python-flask-wtf
(package
(name "python-flask-wtf")
- (version "0.13.1")
+ (version "0.14.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Flask-WTF" version))
(sha256
(base32
- "04l5743j2dici46038sqlzvf0xzpg8rf7s9ld2x24xv7f4idg990"))))
+ "086pvg2x69n0nczcq7frknfjd8am1zdy8qqpva1sanwb02hf65yl"))))
(build-system python-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-before 'check 'drop-failing-test
+ (replace 'check
(lambda _
- ;; FIXME: This file tries resolving an external server, which
- ;; fails. Try to patch out the offending section instead of
- ;; deleting the whole thing.
- (delete-file "tests/test_recaptcha.py")
- #t)))))
+ (setenv "PYTHONPATH" (string-append "./build/lib:"
+ (getenv "PYTHONPATH")))
+ (invoke "pytest" "-vv"))))))
(propagated-inputs
`(("python-flask-babel" ,python-flask-babel)
("python-babel" ,python-babel)
("python-wtforms" ,python-wtforms)))
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-pytest" ,python-pytest)))
(home-page "https://github.com/lepture/flask-wtf")
(synopsis "Simple integration of Flask and WTForms")
(description "Flask-WTF integrates Flask and WTForms, including CSRF, file