summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2020-03-15 20:09:29 +0100
committerBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2020-03-15 23:10:42 +0100
commit5281ba175b4deb33971d8bfc33b8d5f17d1f61de (patch)
treee2c847355bcf49c292d55ba54c0c2997f9bf447f
parent3e550fc8357f5fe3ecafcc712ddfdc02deb41a8b (diff)
downloadpatches-5281ba175b4deb33971d8bfc33b8d5f17d1f61de.tar
patches-5281ba175b4deb33971d8bfc33b8d5f17d1f61de.tar.gz
gnu: java-qdox: Move version 2.0-M2 side by side with version 1.12.1.
* gnu/packages/java.scm (java-qdox): Move package definition up, such that it is side by side with version 1.12.1.
-rw-r--r--gnu/packages/java.scm58
1 files changed, 29 insertions, 29 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 79bf20dd1d..03ed0c6534 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3334,6 +3334,35 @@ class/interface/method definitions from source files complete with JavaDoc
documentation tools.")
(license license:asl2.0)))
+(define-public java-qdox
+ (package
+ (name "java-qdox")
+ ; Newer version exists, but this version is required by java-plexus-component-metadata
+ (version "2.0-M2")
+ (source (origin
+ (method url-fetch)
+ ;; 2.0-M4, -M5 at https://github.com/paul-hammant/qdox
+ ;; Older releases at https://github.com/codehaus/qdox/
+ ;; Note: The release at maven is pre-generated. The release at
+ ;; github requires jflex.
+ (uri (string-append "https://repo1.maven.org/maven2/"
+ "com/thoughtworks/qdox/qdox/" version
+ "/qdox-" version "-sources.jar"))
+ (sha256
+ (base32
+ "10xxrcaicq6axszcr2jpygisa4ch4sinyx5q7kqqxv4lknrmxp5x"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "qdox.jar"
+ #:tests? #f)); no tests
+ (home-page "https://github.com/codehaus/qdox")
+ (synopsis "Parse definitions from Java source files")
+ (description "QDox is a high speed, small footprint parser for extracting
+class/interface/method definitions from source files complete with JavaDoc
+@code{@@tags}. It is designed to be used by active code generators or
+documentation tools.")
+ (license license:asl2.0)))
+
(define-public java-jarjar
(package
(name "java-jarjar")
@@ -11384,35 +11413,6 @@ Moreover, @code{logback-classic} natively implements the slf4j API so that you
can readily switch back and forth between logback and other logging frameworks
such as log4j or @code{java.util.logging} (JUL).")))
-(define-public java-qdox
- (package
- (name "java-qdox")
- ; Newer version exists, but this version is required by java-plexus-component-metadata
- (version "2.0-M2")
- (source (origin
- (method url-fetch)
- ;; 2.0-M4, -M5 at https://github.com/paul-hammant/qdox
- ;; Older releases at https://github.com/codehaus/qdox/
- ;; Note: The release at maven is pre-generated. The release at
- ;; github requires jflex.
- (uri (string-append "https://repo1.maven.org/maven2/"
- "com/thoughtworks/qdox/qdox/" version
- "/qdox-" version "-sources.jar"))
- (sha256
- (base32
- "10xxrcaicq6axszcr2jpygisa4ch4sinyx5q7kqqxv4lknrmxp5x"))))
- (build-system ant-build-system)
- (arguments
- `(#:jar-name "qdox.jar"
- #:tests? #f)); no tests
- (home-page "https://github.com/codehaus/qdox")
- (synopsis "Parse definitions from Java source files")
- (description "QDox is a high speed, small footprint parser for extracting
-class/interface/method definitions from source files complete with JavaDoc
-@code{@@tags}. It is designed to be used by active code generators or
-documentation tools.")
- (license license:asl2.0)))
-
(define-public java-jgit
(package
(name "java-jgit")