summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-16 03:33:57 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-16 15:45:33 +0100
commit4393dafd320ad5d10d8c87d4ae46ce21fdd4ffb6 (patch)
treeb16b75e0de232e85ab423ec2c8c6bca103fe2960
parent15af040cc35895e779397ab42f53561666d9301a (diff)
downloadpatches-4393dafd320ad5d10d8c87d4ae46ce21fdd4ffb6.tar
patches-4393dafd320ad5d10d8c87d4ae46ce21fdd4ffb6.tar.gz
gnu: python-flask-login: Update to 0.5.0.
* gnu/packages/python-web.scm (python-flask-login): Update to 0.5.0. [arguments]: Remove. [native-inputs]: Remove PYTHON-NOSE and PYTHON-PEP8. Add PYTHON-COVERAGE, PYTHON-PYCODESTYLE. and PYTHON-PYTEST.
-rw-r--r--gnu/packages/python-web.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 985d03f8d1..b17de9953f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2394,7 +2394,7 @@ on the command line.")
(define-public python-flask-login
(package
(name "python-flask-login")
- (version "0.4.1")
+ (version "0.5.0")
(source
(origin
(method git-fetch)
@@ -2403,25 +2403,18 @@ on the command line.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1rj0qwyxapxnp84fi4lhmvh3d91fdiwz7hibw77x3d5i72knqaa9"))))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'avoid-yanc
- ;; Work around '.nosetests-real: error: no such option: --with-yanc'.
- (lambda _
- (setenv "NOCOLOR" "set")
- #t)))))
+ (base32 "11ac924w0y4m0kf3mxnxdlidy88jfa7njw5yyrq16dvnx4iwd8gg"))))
(build-system python-build-system)
(propagated-inputs
`(("python-flask" ,python-flask)))
(native-inputs
;; For tests.
`(("python-blinker" ,python-blinker)
+ ("python-coverage" ,python-coverage)
("python-mock" ,python-mock)
- ("python-nose" ,python-nose)
- ("python-pep8" ,python-pep8)
+ ("python-pycodestyle" ,python-pycodestyle)
("python-pyflakes" ,python-pyflakes)
+ ("python-pytest" ,python-pytest)
("python-semantic-version" ,python-semantic-version)
("python-werkzeug" ,python-werkzeug)))
(home-page "https://github.com/maxcountryman/flask-login")