summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-16 14:20:16 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-16 15:45:37 +0100
commit386d2fd130dd557a81620e8409e05e6be7c7507a (patch)
tree9e736a6d87d876d1c62620f9493e5f2b33f998ba
parenta3a7a0331282a4d39f0f7c71ab551fc3038e835b (diff)
downloadpatches-386d2fd130dd557a81620e8409e05e6be7c7507a.tar
patches-386d2fd130dd557a81620e8409e05e6be7c7507a.tar.gz
gnu: python-zope-location: Update to 4.2.
* gnu/packages/python-web.scm (python-zope-location): Update to 4.2. [native-inputs]: Add PYTHON-ZOPE-TESTRUNNER. [propagated-inputs]: Add PYTHON-ZOPE-INTERFACE.
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 43f62883a8..6ff5482612 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1207,19 +1207,22 @@ brokering, etc.) for which the proxy is responsible.")
(define-public python-zope-location
(package
(name "python-zope-location")
- (version "4.0.3")
+ (version "4.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "zope.location" version))
(sha256
(base32
- "1nj9da4ksiyv3h8n2vpzwd0pb03mdsh7zy87hfpx72b6p2zcwg74"))))
+ "1b40pzl8v00d583d3gsxv1qjdw2dhghlgkbgxl3m07d5r3izj857"))))
(build-system python-build-system)
(arguments
'(#:tests? #f)) ; FIXME: Tests can't find zope.interface.
+ (native-inputs
+ `(("python-zope-testrunner" ,python-zope-testrunner)))
(propagated-inputs
- `(("python-zope-proxy" ,python-zope-proxy)
+ `(("python-zope-interface" ,python-zope-interface)
+ ("python-zope-proxy" ,python-zope-proxy)
("python-zope-schema" ,python-zope-schema)))
(home-page "https://pypi.org/project/zope.location/")
(synopsis "Zope location library")