summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-16 03:41:51 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-16 15:45:33 +0100
commit33901ed8c0a85e9b0badbc7ea042d310bdfac970 (patch)
treeb9d2cdd9fc1bcc0637334e9a380b8efb0c14cd4f
parent4393dafd320ad5d10d8c87d4ae46ce21fdd4ffb6 (diff)
downloadpatches-33901ed8c0a85e9b0badbc7ea042d310bdfac970.tar
patches-33901ed8c0a85e9b0badbc7ea042d310bdfac970.tar.gz
gnu: python-flask-babel: Update to 1.0.0.
* gnu/packages/python-web.scm (python-flask-babel): Update to 1.0.0. [arguments]: New field.
-rw-r--r--gnu/packages/python-web.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b17de9953f..b87764b907 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -440,15 +440,21 @@ between a web browser and web server.")
(define-public python-flask-babel
(package
(name "python-flask-babel")
- (version "0.11.2")
+ (version "1.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Flask-Babel" version))
(sha256
(base32
- "0ff9n165vhf1nhv6807ckhpp224jw7k7sd7jz5kfh3sbpl85gmy0"))))
+ "0gmb165vkwv5v7dxsxa2i3zhafns0fh938m2zdcrv4d8z5l099yn"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (with-directory-excursion "tests"
+ (invoke "python" "tests.py")))))))
(propagated-inputs
`(("python-flask" ,python-flask)
("python-babel" ,python-babel)