summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-15 15:49:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-15 15:49:05 +0100
commitf5eb13b21126375ef3aab00c514aab204309d147 (patch)
tree5be2977470486fdb90e016ae6f9c14c2c3352386
parent4fc26c659297b3ae3b4b00a979b2db1682d1d131 (diff)
downloadpatches-f5eb13b21126375ef3aab00c514aab204309d147.tar
patches-f5eb13b21126375ef3aab00c514aab204309d147.tar.gz
gnu: mesa-opencl: Build with clang@9.
This is a follow-up to commit cf4fdbcb0bf8ef4639dc162e09d152666fc6b89e. * gnu/packages/gl.scm (mesa-opencl)[native-inputs]: Change from CLANG-8 to CLANG-9. (mesa)[inputs]: Add reminder.
-rw-r--r--gnu/packages/gl.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index ea9b2c579e..c82d33037e 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -268,6 +268,7 @@ also known as DXTn or DXTC) for Mesa.")
("libxvmc" ,libxvmc)
,@(match (%current-system)
((or "x86_64-linux" "i686-linux")
+ ;; Note: update the 'clang' input of mesa-opencl when bumping this.
`(("llvm" ,llvm-9)))
(_
`()))
@@ -435,7 +436,7 @@ from software emulation to complete hardware acceleration for modern GPUs.")
`(("libclc" ,libclc)
,@(package-inputs mesa)))
(native-inputs
- `(("clang" ,clang-8)
+ `(("clang" ,clang-9)
,@(package-native-inputs mesa)))))
(define-public mesa-opencl-icd