summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-15 14:54:01 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-15 15:09:08 +0100
commitbaea210c04fd9e36340379b580331c9aeea6378b (patch)
treeed2b46a0c4edeb7d2f9eacfdf73820cffb11d58a
parent745041b59ff90195c5d5aad98310f5ad1a34a693 (diff)
downloadpatches-baea210c04fd9e36340379b580331c9aeea6378b.tar
patches-baea210c04fd9e36340379b580331c9aeea6378b.tar.gz
gnu: python-editor: Update to 1.0.4.
* gnu/packages/python-xyz.scm (python-editor): Update to 1.0.4. [arguments]: New field. [home-page, synopsis]: Adjust indentation.
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 902a197fbb..1d99832772 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9631,19 +9631,19 @@ ISO 8859, etc.).")
(define-public python-editor
(package
(name "python-editor")
- (version "0.5")
+ (version "1.0.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-editor" version))
(sha256
(base32
- "1ypnpgvzpkbwsg4rdvy4sy51j28b5xq9v8pnkwxncn07vqz06p7n"))))
+ "0yrjh8w72ivqxi4i7xsg5b1vz15x8fg51xra7c3bgfyxqnyadzai"))))
(build-system python-build-system)
- (home-page
- "https://github.com/fmoo/python-editor")
- (synopsis
- "Programmatically open an editor, capture the result")
+ (arguments
+ '(#:tests? #f)) ;XXX: needs a TTY and an editor
+ (home-page "https://github.com/fmoo/python-editor")
+ (synopsis "Programmatically open an editor, capture the result")
(description
"python-editor is a library that provides the editor module for
programmatically interfacing with your system's $EDITOR.")