summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-15 13:32:12 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-15 15:09:06 +0100
commit5a9980d55eb1afe5c5bc2561a7cba16b0c16fe7e (patch)
tree0c500ed5848cd7cab37c832fb708a5c5a1ff192c
parentc19930dc6bb60fce283ae00ae21d063780922fc2 (diff)
downloadpatches-5a9980d55eb1afe5c5bc2561a7cba16b0c16fe7e.tar
patches-5a9980d55eb1afe5c5bc2561a7cba16b0c16fe7e.tar.gz
gnu: python-networkx: Update to 2.4.
* gnu/packages/python-xyz.scm (python-networkx): Update to 2.4. [source](uri): Download tarball instead of zipball. [arguments]: New field. [native-inputs]: Remove PYTHON-NOSE and UNZIP. Add PYTHON-PYTEST. [properties]: New field. (python2-networkx): Stick with version 2.2.
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 29 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d444e6ed75..1942a9505d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6118,29 +6118,52 @@ interfaces in an easy and portable manner.")
(define-public python-networkx
(package
(name "python-networkx")
- (version "2.2")
+ (version "2.4")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "networkx" version ".zip"))
+ (uri (pypi-uri "networkx" version))
(sha256
- (base32 "12swxb15299v9vqjsq4z8rgh5sdhvpx497xwnhpnb0gynrx6zra5"))))
+ (base32 "0r2wr7aqay9fwjrgk35fkjzk8lvvb4i4df7ndaqzkr4ndw5zzx7q"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "pytest" "-vv" "--pyargs" "networkx")
+ (format #t "test suite not run~%"))
+ #t)))))
;; python-decorator is needed at runtime.
(propagated-inputs
`(("python-decorator" ,python-decorator)))
(native-inputs
- `(("python-nose" ,python-nose)
- ("unzip" ,unzip)))
+ `(("python-pytest" ,python-pytest)))
(home-page "https://networkx.github.io/")
(synopsis "Python module for creating and manipulating graphs and networks")
(description
"NetworkX is a Python package for the creation, manipulation, and study
of the structure, dynamics, and functions of complex networks.")
+ (properties `((python2-variant . ,(delay python2-networkx))))
(license license:bsd-3)))
+;; NetworkX 2.2 is the last version with support for Python 2.
(define-public python2-networkx
- (package-with-python2 python-networkx))
+ (let ((base (package-with-python2 (strip-python2-variant python-networkx))))
+ (package
+ (inherit base)
+ (version "2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "networkx" version ".zip"))
+ (sha256
+ (base32
+ "12swxb15299v9vqjsq4z8rgh5sdhvpx497xwnhpnb0gynrx6zra5"))))
+ (arguments
+ `(#:python ,python-2))
+ (native-inputs
+ `(("python-nose" ,python2-nose)
+ ("unzip" ,unzip))))))
(define-public python-datrie
(package