summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Schott <sschott@mailbox.org>2020-03-07 16:11:40 +0100
committerChristopher Baines <mail@cbaines.net>2020-03-15 16:41:43 +0000
commit5164a92eaa290ba801c079796c05220027f4842b (patch)
tree3e85839b52b96398019d0331f9e25df74b588024
parenta5e76112b61be33bf3e3ba697148e2465983eeb0 (diff)
downloadpatches-5164a92eaa290ba801c079796c05220027f4842b.tar
patches-5164a92eaa290ba801c079796c05220027f4842b.tar.gz
gnu: Add python-d2to1
* gnu/packages/python-xyz.scm (python-d2to1): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a4774be53c..b11eb18542 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -171,6 +171,27 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-d2to1
+ (package
+ (name "python-d2to1")
+ (version "0.2.12.post1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "d2to1" version))
+ (sha256
+ (base32
+ "09fq7pq1z8d006xh5z75rm2lk61v6yn2xhy53z4gsgibhqb2vvs9"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/embray/d2to1")
+ (synopsis "Allows for distutils2-like setup.cfg files as package metadata
+in python")
+ (description "The python package d2to1 (the d is for distutils) allows
+using distutils2-like setup.cfg files for a package's metadata with a
+distribute/setuptools setup.py script.")
+ (license license:bsd-2)))
+
(define-public python-rawkit
(package
(name "python-rawkit")