summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-15 15:47:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-15 15:47:17 +0100
commit4fc26c659297b3ae3b4b00a979b2db1682d1d131 (patch)
tree07d811c3afad0ef7e8e35833b0274eeb0f00dd49
parent45ebd90c186558556f2fe28ff2eb0cd424768b55 (diff)
downloadpatches-4fc26c659297b3ae3b4b00a979b2db1682d1d131.tar
patches-4fc26c659297b3ae3b4b00a979b2db1682d1d131.tar.gz
gnu: python-tblib: Update to 1.6.0.
* gnu/packages/python-xyz.scm (python-tblib): Update to 1.6.0.
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1d99832772..c3cf14476c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10254,24 +10254,17 @@ own code, responding to click events and updating clock every second.")
(define-public python-tblib
(package
(name "python-tblib")
- (version "1.3.2")
+ (version "1.6.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "tblib" version))
- (sha256 (base32
- "1rsg8h069kqgncyv8fgzyj6qflk6j10cb78pa5jk34ixwq044vj3"))))
+ (sha256
+ (base32
+ "0i136n5pydmd202254wzrdbspkw0br0c9mbxhfs9hpfbahvyx6r2"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'check 'adjust-tests
- (lambda _
- (when (which "python3")
- ;; Adjust the example output to match that of Python 3.7:
- ;; <https://github.com/ionelmc/python-tblib/issues/36>.
- (substitute* "README.rst"
- (("Exception\\('fail',") "Exception('fail'"))
- #t)))
(replace 'check
(lambda _
;; Upstream runs tests after installation and the package itself