summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-04 21:37:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-15 08:52:18 +0200
commit3eca7ff9681b68d19016737dacc0d7a0572af3e6 (patch)
tree02e2ef6eb396b46db67964e9106f6f2d9e32caf7
parentb5ffcbe1af01544cac31f056a700f5382f3e6b14 (diff)
downloadpatches-3eca7ff9681b68d19016737dacc0d7a0572af3e6.tar
patches-3eca7ff9681b68d19016737dacc0d7a0572af3e6.tar.gz
gnu: Add python-blurhash.
* gnu/packages/python-crypto.scm (python-blurhash): New variable.
-rw-r--r--gnu/packages/python-crypto.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 9eee75cbfb..23c06267a7 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -788,6 +788,40 @@ key), SSH public key, ASC-encoded OpenPGP key, APK Android application, LDIFF
file, and more.")
(license license:gpl3)))
+(define-public python-blurhash
+ (package
+ (name "python-blurhash")
+ (version "1.1.4")
+ (source
+ (origin
+ ;; Tests not included in pypi release and releases not tagged in git repo.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/halcy/blurhash-python")
+ (commit "22e081ef1c24da1bb5c5eaa2c1d6649724deaef8")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qq6mhydlp7q3na4kmaq3871h43wh3pyfyxr4b79bia73wjdylxf"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (delete-file "setup.cfg")
+ (invoke "pytest"))))))
+ (native-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-pillow" ,python-pillow)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/halcy/blurhash-python")
+ (synopsis
+ "Pure-Python implementation of the blurhash algorithm")
+ (description
+ "Pure-Python implementation of the blurhash algorithm.")
+ (license license:expat)))
+
(define-public python-ecpy
(package
(name "python-ecpy")