summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-15 13:30:11 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-15 15:09:06 +0100
commit3987715415532aea14c179650bac331ec436882c (patch)
treec9e5d0da9c3945a9b190c6659dd1e6f8e9abd8a1
parent382550f0be8f0023068dbd7005f0a29efeeea455 (diff)
downloadpatches-3987715415532aea14c179650bac331ec436882c.tar
patches-3987715415532aea14c179650bac331ec436882c.tar.gz
gnu: python2-pandas: Fix build with Python 2.7.17.
While at it, fix the inheritance. * gnu/packages/python-science.scm (python2-pandas): Use INHERIT instead of PACKAGE/INHERIT. [source](modules, snippet): New fields.
-rw-r--r--gnu/packages/python-science.scm29
1 files changed, 19 insertions, 10 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 8dcc6e77e6..4b3db6d5e0 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016, 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
@@ -277,12 +277,21 @@ doing practical, real world data analysis in Python.")
(define-public python2-pandas
(let ((pandas (package-with-python2
(strip-python2-variant python-pandas))))
- (package/inherit
- pandas
- (version "0.24.2")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "pandas" version))
- (sha256
- (base32
- "18imlm8xbhcbwy4wa957a1fkamrcb0z988z006jpfda3ki09z4ag")))))))
+ (package
+ (inherit pandas)
+ (version "0.24.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pandas" version))
+ (sha256
+ (base32
+ "18imlm8xbhcbwy4wa957a1fkamrcb0z988z006jpfda3ki09z4ag"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Adjust for renamed error message in Python 2.7.17. Taken
+ ;; from <https://github.com/pandas-dev/pandas/pull/29294>.
+ (substitute* "pandas/io/parsers.py"
+ (("if 'NULL byte' in msg:")
+ "if 'NULL byte' in msg or 'line contains NUL' in msg:"))
+ #t)))))))