summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-03-12 01:51:12 +0100
committerLeo Famulari <leo@famulari.name>2020-03-15 13:54:00 -0400
commit323841bda4e5b8f9b30626ab768aaf711ee6aabf (patch)
tree56790b95d68cf41ccaafc9d490941b9b085ef6fc
parentcd773f118573aad42c1e10dd77061fd3d1279189 (diff)
downloadpatches-323841bda4e5b8f9b30626ab768aaf711ee6aabf.tar
patches-323841bda4e5b8f9b30626ab768aaf711ee6aabf.tar.gz
gnu: Add nvme-cli
* gnu/packages/linux.scm (nvme-cli): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/linux.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 688d9eefaf..f1bc5798ab 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3577,6 +3577,36 @@ IDE driver subsystem. Many external USB drive enclosures with SCSI-ATA Command
Translation (@dfn{SAT}) are also supported.")
(license (license:non-copyleft "file://LICENSE.TXT"))))
+(define-public nvme-cli
+ (package
+ (name "nvme-cli")
+ (version "1.10.1")
+ (home-page "https://github.com/linux-nvme/nvme-cli")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "12wp2wxmsw2v8m9bhvwvdbhdgx1md8iilhbl19sfzz2araiwi2x8"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "CC=gcc")
+ #:phases (modify-phases %standard-phases
+ (delete 'configure) ; No ./configure script
+ (replace 'install
+ (lambda _
+ (invoke "make" "install-spec" "PREFIX="
+ (string-append "DESTDIR=" %output)))))
+ #:tests? #f)) ; The tests require sysfs, which is not accessible from
+ ; the build environment
+ (synopsis "NVM-Express user space tooling for Linux")
+ (description "Nvme-cli is a utility to provide standards compliant tooling
+for NVM-Express drives. It was made specifically for Linux as it relies on the
+IOCTLs defined by the mainline kernel driver.")
+ (license license:gpl2+)))
+
(define-public rfkill
(package
(name "rfkill")