summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Schott <sschott@mailbox.org>2020-03-07 16:11:45 +0100
committerChristopher Baines <mail@cbaines.net>2020-03-15 16:41:44 +0000
commit2f12e6608b8dd071e37264c63ea86dcdfb8aaa84 (patch)
treeca387affbd9ec44d6947e8e296abfa80e3a24b2c
parentdcf953299505274e542ea8c79141b21f1f18277d (diff)
downloadpatches-2f12e6608b8dd071e37264c63ea86dcdfb8aaa84.tar
patches-2f12e6608b8dd071e37264c63ea86dcdfb8aaa84.tar.gz
gnu: Add python-tenacity
* gnu/packages/python-xyz.scm (python-tenacity): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2dd3d04706..2718e9b236 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -171,6 +171,36 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-tenacity
+ (package
+ (name "python-tenacity")
+ (version "6.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "tenacity" version))
+ (sha256
+ (base32
+ "1j36v9fcpmmd4985ix0cwnvcq71rkrn5cjiiv0id9vkl4kpxh0gv"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-sphinx" ,python-sphinx)
+ ("python-tornado" ,python-tornado)
+ ("python-pytest" ,python-pytest)))
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest")
+ #t)))))
+ (home-page "https://github.com/jd/tenacity")
+ (synopsis "Retrying library for python")
+ (description "Tenacity is a general-purpose python library to simplify the
+task of adding retry behavior to just about anything.")
+ (license license:asl2.0)))
+
(define-public python-colorlog
(package
(name "python-colorlog")