summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Schott <sschott@mailbox.org>2020-03-07 16:11:41 +0100
committerChristopher Baines <mail@cbaines.net>2020-03-15 16:41:43 +0000
commit2763f0de41c62623622d2eb9d4c17c04d62afcbd (patch)
tree9fe58a583c5614a920a1ea50f2b4a794d394372a
parent5164a92eaa290ba801c079796c05220027f4842b (diff)
downloadpatches-2763f0de41c62623622d2eb9d4c17c04d62afcbd.tar
patches-2763f0de41c62623622d2eb9d4c17c04d62afcbd.tar.gz
gnu: Add python-colour
* gnu/packages/python-xyz.scm (python-colour): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b11eb18542..4de78fdf27 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -171,6 +171,25 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-colour
+ (package
+ (name "python-colour")
+ (version "0.1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "colour" version))
+ (sha256
+ (base32
+ "1visbisfini5j14bdzgs95yssw6sm4pfzyq1n3lfvbyjxw7i485g"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-d2to1" ,python-d2to1)))
+ (home-page "https://github.com/vaab/colour")
+ (synopsis "Convert and manipulate various color representations")
+ (description "Pythonic way to manipulate color representations (HSL, RVB,
+web, X11, ...).")
+ (license license:expat)))
+
(define-public python-d2to1
(package
(name "python-d2to1")