summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Schott <sschott@mailbox.org>2020-03-07 16:11:43 +0100
committerChristopher Baines <mail@cbaines.net>2020-03-15 16:41:43 +0000
commit23fde56b330c0d27f6cff161ab16d857d8975303 (patch)
treea6b3a6fd7992d65b1caac43d24259e8ea1fd1187
parentf3465dee986ffab4bba27839b2d1d5d4a050d835 (diff)
downloadpatches-23fde56b330c0d27f6cff161ab16d857d8975303.tar
patches-23fde56b330c0d27f6cff161ab16d857d8975303.tar.gz
gnu: Add python-pyprind
* gnu/packages/python-xyz.scm (python-pyprind): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3ff7bc45a5..26e1927cb9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -171,6 +171,26 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-pyprind
+ (package
+ (name "python-pyprind")
+ (version "2.11.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyPrind" version))
+ (sha256
+ (base32
+ "0xg6m5hr33h9bdlrr42kc58jm2m87a9zsagy7n2m4n407d2snv64"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-psutil" ,python-psutil)))
+ (home-page "https://github.com/rasbt/pyprind")
+ (synopsis "Python Progress Bar and Percent Indicator Utility")
+ (description "The PyPrind (Python Progress Indicator) module provides a
+progress bar and a percentage indicator object that let you track the progress
+of a loop structure or other iterative computation.")
+ (license license:bsd-3)))
+
(define-public python-gphoto2
(package
(name "python-gphoto2")