summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-02-24 11:51:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-02-24 12:31:31 +0200
commitfbf983c013299616b77fb97af595edd104eee28d (patch)
tree8ab3be5ba803887ac0da8155dd8b58c386eaf0dd
parent9ea458c57a1c539669e0976011215d021a79d614 (diff)
downloadpatches-fbf983c013299616b77fb97af595edd104eee28d.tar
patches-fbf983c013299616b77fb97af595edd104eee28d.tar.gz
gnu: Add rust-serde-cbor-0.11.
* gnu/packages/crates-io.scm (rust-serde-cbor-0.11): New variable. (rust-serde-cbor-0.10): Inherit from rust-serde-cbor-0.11.
-rw-r--r--gnu/packages/crates-io.scm33
1 files changed, 27 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b570b65ec5..f8fb2f3867 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -13492,8 +13492,34 @@ proven statistical guarantees.")
"Optimized handling of @code{&[u8]} and @code{Vec<u8>} for Serde.")
(license (list license:expat license:asl2.0))))
+(define-public rust-serde-cbor-0.11
+ (package
+ (name "rust-serde-cbor")
+ (version "0.11.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "serde-cbor" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "08m62mfqjnpa543kd9r9cyxlqc6y73avhsl3n8svgs4h5zxaq60y"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-half" ,rust-half-1.3)
+ ("rust-serde" ,rust-serde-1.0))
+ #:cargo-development-inputs
+ (("rust-serde-derive" ,rust-serde-derive-1.0))))
+ (home-page "https://github.com/pyfisch/cbor")
+ (synopsis "CBOR support for serde")
+ (description "CBOR support for serde.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-serde-cbor-0.10
(package
+ (inherit rust-serde-cbor-0.11)
(name "rust-serde-cbor")
(version "0.10.2")
(source
@@ -13505,7 +13531,6 @@ proven statistical guarantees.")
(sha256
(base32
"0kyizacjabsa78p9f7qvj31zirpnsgsr4zpfv1p6lwpcb3biw27p"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
@@ -13513,11 +13538,7 @@ proven statistical guarantees.")
("rust-half" ,rust-half-1.3)
("rust-serde" ,rust-serde-1.0))
#:cargo-development-inputs
- (("rust-serde-derive" ,rust-serde-derive-1.0))))
- (home-page "https://github.com/pyfisch/cbor")
- (synopsis "CBOR support for serde")
- (description "CBOR support for serde.")
- (license (list license:expat license:asl2.0))))
+ (("rust-serde-derive" ,rust-serde-derive-1.0))))))
(define-public rust-serde-codegen-0.4
(package