summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-03-14 13:02:23 +0100
committerJakub Kądziołka <kuba@kadziolka.net>2020-03-14 13:14:59 +0100
commitce226e9d8d52d2530f057f2000d36c0d55380ade (patch)
tree5ff48381b2b6c12b6a0758dc674dff7cbc8566d0
parentaebba13c0bef5a58697f1a9fe8337967cc01300f (diff)
downloadpatches-ce226e9d8d52d2530f057f2000d36c0d55380ade.tar
patches-ce226e9d8d52d2530f057f2000d36c0d55380ade.tar.gz
gnu: Add superfamiconv
* gnu/packages/graphics.scm (superfamiconv): New variable.
-rw-r--r--gnu/packages/graphics.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 7414edb4fe..f5ebfaacaa 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1075,3 +1076,37 @@ interaction library, written in C++, which has become the de facto
standard graphics library for 3D visualization and visual simulation
software in the scientific and engineering community.")
(license license:bsd-3))))
+
+(define-public superfamiconv
+ (package
+ (name "superfamiconv")
+ (version "0.8.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Optiroc/SuperFamiconv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0848szv6a2b8wdganh6mw5i8vn8cqvn1kbwzx7mb9wlrf5wzqn37"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((outdir (assoc-ref outputs "out"))
+ (bindir (string-append outdir "/bin")))
+ (install-file "bin/superfamiconv" bindir)
+ #t))))))
+ (home-page "https://github.com/Optiroc/SuperFamiconv")
+ (synopsis "Tile graphics converter supporting SNES, Game Boy Color
+and PC Engine formats")
+ (description "SuperFamiconv is a converter for tiled graphics, supporting
+the graphics formats of the SNES, Game Boy Color and PC Engine game consoles.
+Automated palette selection is supported.")
+ (license license:expat)))