summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-14 17:30:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-14 17:31:40 +0100
commitabb0ff45487a280d3ab171460b5448620de4b358 (patch)
tree6354958df3c212586eea4fb2049094c43bccd197
parentad1edd03adb1f4412cc50563c8b8530031c65ed7 (diff)
downloadpatches-abb0ff45487a280d3ab171460b5448620de4b358.tar
patches-abb0ff45487a280d3ab171460b5448620de4b358.tar.gz
gnu: Add guile3.0-chickadee.
* gnu/packages/game-development.scm (guile3.0-chickadee): New variable.
-rw-r--r--gnu/packages/game-development.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 7638a545ca..bf3b12ffd3 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1774,6 +1774,42 @@ that parenthetically inclined game developers need to make 2D (and eventually
@end enumerate\n")
(license license:gpl3+)))
+(define-public guile3.0-chickadee
+ (package
+ (inherit guile-chickadee)
+ (name "guile-chickadee")
+ (version "0.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://files.dthompson.us/chickadee/"
+ "chickadee-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1fdicsgls5cp0yffcm5vjmav67gv9bxhz1s3jvdvinspxb485x7l"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ `(("guile-opengl" ,guile3.0-opengl)
+ ("guile-sdl2" ,guile3.0-sdl2)))
+ (inputs
+ `(("guile" ,guile-3.0)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
+ (home-page "https://dthompson.us/projects/chickadee.html")
+ (synopsis "Game development toolkit for Guile Scheme with SDL2 and OpenGL")
+ (description "Chickadee is a game development toolkit for Guile Scheme
+built on top of SDL2 and OpenGL. Chickadee aims to provide all the features
+that parenthetically inclined game developers need to make 2D (and eventually
+3D) games in Scheme, such as:
+
+@enumerate
+@item extensible, fixed-timestep game loop
+@item OpenGL-based rendering engine
+@item keyboard, mouse, controller input
+@item REPL-driven development model
+@end enumerate\n")
+ (license license:gpl3+)))
+
(define-public bennu-game-development
(package
(name "bennu-game-development")