summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-14 11:31:03 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 11:55:34 +0100
commita92a93c9a47f26de8aed907e573aee7aed5fa92f (patch)
treede28a128e7f9e649e18f97047125be96ef8ba1c0
parent6d84566e5e0dc8adddd0b68888fd3b317323718d (diff)
downloadpatches-a92a93c9a47f26de8aed907e573aee7aed5fa92f.tar
patches-a92a93c9a47f26de8aed907e573aee7aed5fa92f.tar.gz
gnu: cppzmq: Update to 4.6.0.
* gnu/packages/networking.scm (cppzmq): Update to 4.6.0. [arguments]: Add #:configure-flags.
-rw-r--r--gnu/packages/networking.scm56
1 files changed, 29 insertions, 27 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 9fd58a5659..4fa5008149 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2018 Tonton <tonton@riseup.net>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Theodoros Foradis <theodoros@foradis.org>
-;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -342,33 +342,35 @@ between different versions of ØMQ.")
(license license:mpl2.0)))
(define-public cppzmq
- (let ((revision "0")
- (commit "d9f0f016c07046742738c65e1eb84722ae32d7d4"))
- (package
- (name "cppzmq")
- (version (string-append "4.2.2-" revision "."
- (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/zeromq/cppzmq")
- (commit commit)))
- (sha256
- (base32
- "1gmqlm00y6xpa5m6d4ajq3ww63n2w7h4sy997wj81vcqmqx45b1f"))
- (file-name (string-append name "-" version "-checkout"))))
- (build-system cmake-build-system)
- (arguments '(#:tests? #f)) ; No tests.
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("zeromq" ,zeromq)))
- (home-page "http://zeromq.org")
- (synopsis "C++ bindings for the ØMQ messaging library")
- (description
- "This package provides header-only C++ bindings for ØMQ. The header
+ (package
+ (name "cppzmq")
+ (version "4.6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zeromq/cppzmq")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "19acx2bzi4n6fdnfgkja1nds7m1bwg8lw5vfcijrx9fv75pa7m8h"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ '(;; FIXME: The test suite requires downloading Catch and custom
+ ;; CMake targets, and refuses to use the system version.
+ ;; See <https://github.com/zeromq/cppzmq/issues/334>.
+ #:tests? #f
+ #:configure-flags '("-DCPPZMQ_BUILD_TESTS=OFF")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("zeromq" ,zeromq)))
+ (home-page "http://zeromq.org")
+ (synopsis "C++ bindings for the ØMQ messaging library")
+ (description
+ "This package provides header-only C++ bindings for ØMQ. The header
files contain direct mappings of the abstractions provided by the ØMQ C API.")
- (license license:expat))))
+ (license license:expat)))
(define-public librdkafka
(package