summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-14 17:42:41 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-14 18:34:02 +0100
commit5edad6c75ae86a1e57010d7b4dce253f72ab3860 (patch)
treea674f1c5463dea61489eaa784e3990d3664612df
parent7f8c5111fc5d6c1f27e7aaf4a1c2369e77f5f50d (diff)
downloadpatches-5edad6c75ae86a1e57010d7b4dce253f72ab3860.tar
patches-5edad6c75ae86a1e57010d7b4dce253f72ab3860.tar.gz
gnu: mesa: Update to 19.3.4.
* gnu/packages/gl.scm (mesa): Update to 19.3.4. (mesa-19.3.3): Remove variable. * gnu/packages/graphics.scm (opensubdiv)[inputs]: Remove MESA-19.3.3.
-rw-r--r--gnu/packages/gl.scm22
-rw-r--r--gnu/packages/graphics.scm5
2 files changed, 3 insertions, 24 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index e610fe1dd7..119440580a 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -232,7 +232,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "19.3.2")
+ (version "19.3.4")
(source
(origin
(method url-fetch)
@@ -244,7 +244,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "1hg1gvcwvayksrdh9z8rfz66h3z1ffspmm2qgyy2nd8n8qrfwfjf"))
+ "1r4giqq7q7zqbn23lbw7v5vswagxx8qj6ij2w8bsb697mvk6g90x"))
(patches
(search-patches "mesa-skip-disk-cache-test.patch"))))
(build-system meson-build-system)
@@ -423,24 +423,6 @@ device drivers allows Mesa to be used in many different environments ranging
from software emulation to complete hardware acceleration for modern GPUs.")
(license license:x11)))
-;; Mesa 19.3.2 causes a test failure in some packages, so add this newer
-;; version separately until the next rebuild cycle.
-(define-public mesa-19.3.3
- (package/inherit
- mesa
- (version "19.3.3")
- (source (origin
- (inherit (package-source mesa))
- (uri (list (string-append "https://mesa.freedesktop.org/archive/"
- "mesa-" version ".tar.xz")
- (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
- "mesa-" version ".tar.xz")
- (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
- version "/mesa-" version ".tar.xz")))
- (sha256
- (base32
- "02czqdqf64i3az5p1allnxycyjad3x35cj0hz0017mi5pc84ikl1"))))))
-
(define-public mesa-opencl
(package
(inherit mesa)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index a7ea6192fb..c49ba69475 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1061,10 +1061,7 @@ requirements.")
(native-inputs
`(("xorg-server" ,xorg-server-for-tests)))
(inputs
- `(;; The test suite fails when using Mesa 19.3.2, so we provide this newer
- ;; version. Remove this input when the 'mesa' package is updated.
- ("mesa" ,mesa-19.3.3)
- ("glew" ,glew)
+ `(("glew" ,glew)
("libxrandr" ,libxrandr)
("libxcursor" ,libxcursor)
("libxinerama" ,libxinerama)