summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-11 17:46:04 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-11 17:46:04 +0100
commit4510aeb91ce6267a14c9cead768869553b3a2279 (patch)
treebc247baba6a6a7cf668b5280b870ba8cfc6c4ac9
parent2d421c4f19a0669879c9a8738361a151b1431d4f (diff)
downloadpatches-4510aeb91ce6267a14c9cead768869553b3a2279.tar
patches-4510aeb91ce6267a14c9cead768869553b3a2279.tar.gz
gnu: python2-sphinx: Build with python-docutils@0.14.
* gnu/packages/python-xyz.scm (python2-docutils-0.14): New public variable. * gnu/packages/sphinx.scm (python2-sphinx)[propagated-inputs]: Change from PYTHON2-DOCUTILS to PYTHON2-DOCUTILS-0.14.
-rw-r--r--gnu/packages/python-xyz.scm12
-rw-r--r--gnu/packages/sphinx.scm2
2 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8576b1ecf9..94eff2c85b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2703,6 +2703,18 @@ reStructuredText.")
(define-public python2-docutils
(package-with-python2 python-docutils))
+;; python2-sphinx fails its test suite with newer versions.
+(define-public python2-docutils-0.14
+ (package
+ (inherit python2-docutils)
+ (version "0.14")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "docutils" version))
+ (sha256
+ (base32
+ "0x22fs3pdmr42kvz6c654756wja305qv6cx1zbhwlagvxgr4xrji"))))))
+
(define-public python-pygments
(package
(name "python-pygments")
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 323d5b4457..ff5d8e5de7 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -137,7 +137,7 @@ sources.")
,python2-sphinx-alabaster-theme)
("python2-babel" ,python2-babel-2.6)
("python2-snowballstemmer" ,python2-snowballstemmer)
- ("python2-docutils" ,python2-docutils)
+ ("python2-docutils" ,python2-docutils-0.14)
("python2-jinja2" ,python2-jinja2)
("python2-packaging" ,python2-packaging)
("python2-pygments" ,python2-pygments)