summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 18:53:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:40 +0100
commit1442ca73402ba7904830204e59aa2d76bd85af46 (patch)
treed20e0ec33a4c59a4574a9152ee42a7100224b179
parent390bc8726bbd9625557f1cd02b3853995de34b8f (diff)
downloadpatches-1442ca73402ba7904830204e59aa2d76bd85af46.tar
patches-1442ca73402ba7904830204e59aa2d76bd85af46.tar.gz
gnu: Add r-acebayes.
* gnu/packages/cran.scm (r-acebayes): New variable.
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1a09342180..91f842e8f4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16965,3 +16965,34 @@ See e.g. Gentle (2003) @url{doi:10.1007/b97336}.")
"This package provides a number of methods for creating and augmenting
Latin Hypercube Samples.")
(license license:gpl3)))
+
+(define-public r-acebayes
+ (package
+ (name "r-acebayes")
+ (version "1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "acebayes" version))
+ (sha256
+ (base32
+ "1xm6bw0qm2vlcrk274x0bawzb2lnacb1wsmzba5mg3i75a55pqln"))))
+ (properties `((upstream-name . "acebayes")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-compare" ,r-compare)
+ ("r-lhs" ,r-lhs)
+ ("r-randtoolbox" ,r-randtoolbox)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)))
+ (home-page "https://cran.r-project.org/web/packages/acebayes/")
+ (synopsis "Optimal Bayesian experimental design using the ACE algorithm")
+ (description
+ "Finding an optimal Bayesian experimental design involves maximizing an
+objective function given by the expectation of some appropriately chosen
+utility function with respect to the joint distribution of unknown
+quantities (including responses). This objective function is usually not
+available in closed form and the design space can be continuous and of high
+dimensionality. This package uses @dfn{Approximate Coordinate Exchange} (ACE)
+to maximise an approximation to the expectation of the utility function.")
+ (license license:gpl2)))