summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-24 19:39:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-24 19:39:17 +0100
commit132c1915a5988375e5747db6e8376e7f63ba4803 (patch)
tree04e2402a1c09dcb3d2b80ae47ef9f6e832527766
parentcf4fdbcb0bf8ef4639dc162e09d152666fc6b89e (diff)
downloadpatches-132c1915a5988375e5747db6e8376e7f63ba4803.tar
patches-132c1915a5988375e5747db6e8376e7f63ba4803.tar.gz
gnu: qtbase: Remove custom 'qtbase-patched' variant.
* gnu/packages/qt.scm (qtbase)[source](patches): Add 'qtbase-QTBUG-81715.patch. (qtbase-patched): Remove variable. * gnu/packages/engineering.scm (freecad)[inputs]: Change from QTBASE-PATCHED to QTBASE.
-rw-r--r--gnu/packages/engineering.scm2
-rw-r--r--gnu/packages/qt.scm18
2 files changed, 3 insertions, 17 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 33c12215e3..f3fa9e2597 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2283,7 +2283,7 @@ full programmatic control over your models.")
("python-pyside-2-tools" ,python-pyside-2-tools)
("python-shiboken-2" ,python-shiboken-2)
("python-wrapper" ,python-wrapper)
- ("qtbase" ,qtbase-patched)
+ ("qtbase" ,qtbase)
("qtsvg" ,qtsvg)
("qtx11extras" ,qtx11extras)
("qtxmlpatterns" ,qtxmlpatterns)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 7aa9d0f0f9..6642ed6e77 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -351,7 +351,8 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(base32
"0pb68d30clksdhgy8n6rrs838bb3qcsfq4pv463yy2nr4p5kk2di"))
;; Use TZDIR to avoid depending on package "tzdata".
- (patches (search-patches "qtbase-use-TZDIR.patch"))
+ (patches (search-patches "qtbase-use-TZDIR.patch"
+ "qtbase-QTBUG-81715.patch"))
(modules '((guix build utils)))
(snippet
;; corelib uses bundled harfbuzz, md4, md5, sha3
@@ -598,24 +599,9 @@ developers using C++ or QML, a CSS & JavaScript like language.")
developers using C++ or QML, a CSS & JavaScript like language.")
(license (list license:lgpl2.1 license:lgpl3))))
-;; This variant fixes a problem with the CMake macros shipped by qtbase. See
-;; discussion at <https://lists.gnu.org/archive/html/guix-devel/2020-02/msg00308.html>.
-(define-public qtbase-patched
- (let ((src (package-source qtbase)))
- (hidden-package
- (package
- (inherit qtbase)
- (source
- (origin
- (inherit src)
- (patches
- (append (search-patches "qtbase-QTBUG-81715.patch")
- (origin-patches src)))))))))
-
;; qt used to refer to the monolithic Qt 5.x package
(define-deprecated qt qtbase)
-
(define-public qtsvg
(package (inherit qtbase)
(name "qtsvg")