summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-12 20:13:40 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-14 18:34:01 +0100
commitdce9b8b52c0726805e4e8f223e7cc9839d7bf7cf (patch)
tree9bf53629328db224c0b1e7371f9c64bfe8fd7298
parent3c8ad0876c9245ce7f712d52ace287bb29d4ad4d (diff)
downloadpatches-dce9b8b52c0726805e4e8f223e7cc9839d7bf7cf.tar
patches-dce9b8b52c0726805e4e8f223e7cc9839d7bf7cf.tar.gz
gnu: python-jinja2: Run the tests.
* gnu/packages/python-xyz.scm (python-jinja2)[native-inputs]: Add PYTHON-PYTEST. [arguments]: New field.
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0457fa9ea7..63d6f4bf9b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2459,6 +2459,20 @@ for Python.")
(base32
"0l72c11n959yzb8d3ankckb6yhjhm6x729zm7rkpk040qzxpy64k"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (begin
+ (setenv "PYTHONPATH"
+ (string-append "./build/lib:"
+ (getenv "PYTHONPATH")))
+ (invoke "pytest" "-vv"))
+ (format #t "test suite not run~%"))
+ #t)))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(propagated-inputs
`(("python-markupsafe" ,python-markupsafe)))
(home-page "http://jinja.pocoo.org/")