summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2020-03-12 16:38:44 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-12 18:32:16 +0100
commite0dbed64c530916ab600f193f5f6f6ad6177f7b3 (patch)
tree1c573fdbf5fe4bf3512a5baaaafd4d2dbccc1d1d
parent22464cf32abcd38311eb29001a23b26f8c4c54dc (diff)
downloadpatches-e0dbed64c530916ab600f193f5f6f6ad6177f7b3.tar
patches-e0dbed64c530916ab600f193f5f6f6ad6177f7b3.tar.gz
gnu: singularity: Do not use the "errors=remount-ro" squashfs option.
This mount option stopped being supported with Linux-libre 5.4.5: http://ci.guix.gnu.org/build/2056359/details * gnu/packages/linux.scm (singularity)[source]: Remove "errors=remount-ro" mount option from source code.
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e864e17800..01986222e8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3482,6 +3482,12 @@ thanks to the use of namespaces.")
_ program)
(string-append "/run/setuid-programs/singularity-"
program "-helper")))
+
+ ;; These squashfs mount options are apparently no longer
+ ;; supported since Linux-libre 5.4.5.
+ (substitute* "src/lib/image/squashfs/mount.c"
+ (("\"errors=remount-ro\"")
+ "NULL"))
#t))))
(build-system gnu-build-system)
(arguments