summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2020-01-10 13:32:32 -0600
committerAlex Griffin <a@ajgrf.com>2020-03-12 21:12:03 -0500
commitaff95768117381547a60f81f4a58d1d5582afc1a (patch)
tree4d05313872348e35961bb76bd45a87e925b381a1
parent8320c72587255ab6649c32ef838762058ae95c5b (diff)
downloadpatches-aff95768117381547a60f81f4a58d1d5582afc1a.tar
patches-aff95768117381547a60f81f4a58d1d5582afc1a.tar.gz
gnu: Add go-github-com-rifflock-lfshook.
* gnu/packages/golang.scm (go-github-com-rifflock-lfshook): New variable.
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3b4e5192e5..470013b052 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1181,6 +1181,31 @@ GNU extensions} to the POSIX recommendations for command-line options.")
compatible with the standard library logger.")
(license license:expat)))
+(define-public go-github-com-rifflock-lfshook
+ (package
+ (name "go-github-com-rifflock-lfshook")
+ (version "2.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rifflock/lfshook.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wxqjcjfg8c0klmdgmbw3ckagby3wg9rkga9ihd4fsf05x5scxrc"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/rifflock/lfshook"))
+ (propagated-inputs
+ `(("go-github-com-sirupsen-logrus" ,go-github-com-sirupsen-logrus)))
+ (home-page "https://github.com/rifflock/lfshook")
+ (synopsis "Local File System hook for Logrus logger")
+ (description "This package provides a hook for Logrus to write directly to
+a file on the filesystem. The log levels are dynamic at instantiation of the
+hook, so it is capable of logging at some or all levels.")
+ (license license:expat)))
+
(define-public go-github-com-kardianos-osext
(let ((commit "ae77be60afb1dcacde03767a8c37337fad28ac14")
(revision "1"))