summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-11-14 10:11:24 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-11-14 10:14:03 +0100
commita9b66019085bfcda9fd726d384345550bc2acdff (patch)
tree141b92f687f94111db33e7c4ddf4ba4a168ff82e
parent7696af421b9fa05f479cda9c742883a99e6faec3 (diff)
downloadpatches-a9b66019085bfcda9fd726d384345550bc2acdff.tar
patches-a9b66019085bfcda9fd726d384345550bc2acdff.tar.gz
gnu: Add r-renv.
* gnu/packages/cran.scm (r-renv): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4662680b19..9a3141c9e4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5464,6 +5464,29 @@ user's computer should be used to save data, caches and logs. It is a port of
Python's @url{https://github.com/ActiveState/appdirs,Appdirs} to R.")
(license license:expat)))
+(define-public r-renv
+ (package
+ (name "r-renv")
+ (version "0.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "renv" version))
+ (sha256
+ (base32
+ "0034jlaq7z40q3hcpkjlaff37dpn46kvxvzw4scbwlw4x9q8sx9j"))))
+ (properties `((upstream-name . "renv")))
+ (build-system r-build-system)
+ (home-page "https://rstudio.github.io/renv")
+ (synopsis "Project environments")
+ (description
+ "This package provides a dependency management toolkit for R. Using
+renv, you can create and manage project-local R libraries, save the state of
+these libraries to a lockfile, and later restore your library as required.
+Together, these tools can help make your projects more isolated, portable, and
+reproducible.")
+ (license license:expat)))
+
(define-public r-learnr
(package
(name "r-learnr")