summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCyrill Schenkel <cyrill.schenkel@gmail.com>2015-10-23 16:38:16 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-27 00:01:20 +0100
commit7dae1f4301323e5789b93e04786977c87aa8c8da (patch)
treeca3ca0ead043236dc768ac7f83003477f06b508d
parent06d45f4566469364b4c1fe6d3c71ecf58f5d4838 (diff)
downloadpatches-7dae1f4301323e5789b93e04786977c87aa8c8da.tar
patches-7dae1f4301323e5789b93e04786977c87aa8c8da.tar.gz
gnu: Add xcompmgr.
* gnu/packages/xorg.scm (xcompmgr): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/xorg.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index b39bbd436f..a891fcc06b 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
+;;; Copyright © 2015 Cyrill Schenkel <cyrill.schenkel@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5439,3 +5440,44 @@ perl programs to display windows and graphics on X11 servers.")
;; of the extension modules in the directory Protocol/Ext: see those files
;; for details)."
(license (package-license perl))))
+
+(define-public xcompmgr
+ (package
+ (name "xcompmgr")
+ (version "1.1.7")
+ (source
+ (origin
+ ;; there's no current tarball
+ (method git-fetch)
+ (uri (git-reference
+ (url "http://anongit.freedesktop.org/git/xorg/app/xcompmgr.git")
+ (commit (string-append name "-" version))))
+ (sha256
+ (base32
+ "04swkrm3gk689wrjc418bd3n25w8r20kg1xfbn5j8d7mx1r5gf16"))
+ (file-name (string-append name "-" version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'autogen
+ (lambda _
+ (setenv "NOCONFIGURE" "t")
+ (zero? (system* "sh" "autogen.sh")))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (inputs
+ `(("libX11" ,libx11)
+ ("libXext" ,libxext)
+ ("libXcomposite" ,libxcomposite)
+ ("libXfixes" ,libxfixes)
+ ("libXdamage" ,libxdamage)
+ ("libXrender" ,libxrender)))
+ (synopsis "X Compositing manager using RENDER")
+ (description "xcompmgr is a sample compositing manager for X servers
+supporting the XFIXES, DAMAGE, RENDER, and COMPOSITE extensions. It enables
+basic eye-candy effects.")
+ (home-page "http://cgit.freedesktop.org/xorg/app/xcompmgr/")
+ (license (license:x11-style
+ "http://cgit.freedesktop.org/xorg/app/xcompmgr/tree/COPYING"))))