summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2020-01-10 13:36:57 -0600
committerAlex Griffin <a@ajgrf.com>2020-03-12 21:12:04 -0500
commit42c6503d3777cf1b1c3749efe847dc8025a34b94 (patch)
tree6867b587a24d17d6629b8eb94d88895b3576e03c
parentaff95768117381547a60f81f4a58d1d5582afc1a (diff)
downloadpatches-42c6503d3777cf1b1c3749efe847dc8025a34b94.tar
patches-42c6503d3777cf1b1c3749efe847dc8025a34b94.tar.gz
gnu: Add go-github-com-mattn-go-zglob.
* gnu/packages/golang.scm (go-github-com-mattn-go-zglob): New variable.
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 470013b052..0d92139311 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3374,3 +3374,25 @@ test results.")
data serialization format.")
(home-page "https://github.com/golang/protobuf")
(license license:bsd-3)))
+
+(define-public go-github-com-mattn-go-zglob
+ (package
+ (name "go-github-com-mattn-go-zglob")
+ (version "0.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mattn/go-zglob.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1sncdyq5fbd42al4amyy91h7vlzm3wm6c9vl8za2pjgfgsd581fz"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/mattn/go-zglob"))
+ (home-page "https://github.com/mattn/go-zglob")
+ (synopsis "Glob library that descends into other directories")
+ (description " A glob library that implements descending into other
+directories. It is optimized for filewalking. ")
+ (license license:expat)))