summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-03-09 17:31:25 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-12 15:34:28 +0200
commit37109658a589285c3d70197adfdca20f1c48c355 (patch)
tree1d357b7bf58822a7fe769f1ad1b5b5beafbd1d9c
parentd56d3ae704a74e592368a7afc69e1d109ea967f4 (diff)
downloadpatches-37109658a589285c3d70197adfdca20f1c48c355.tar
patches-37109658a589285c3d70197adfdca20f1c48c355.tar.gz
gnu: Add hyperledger-iroha-ed25519.
* gnu/packages/hyperledger.scm (hyperledger-iroha-ed25519): New variable.
-rw-r--r--gnu/packages/hyperledger.scm45
1 files changed, 44 insertions, 1 deletions
diff --git a/gnu/packages/hyperledger.scm b/gnu/packages/hyperledger.scm
index 158a66e898..71194fba38 100644
--- a/gnu/packages/hyperledger.scm
+++ b/gnu/packages/hyperledger.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019, 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -93,3 +93,46 @@ solutions, underpinned by a modular architecture focusing on confidentiality
and resiliency. It is designed to support pluggable implementations of
different components.")
(license asl2.0)))
+
+(define-public hyperledger-iroha-ed25519
+ (package
+ (name "hyperledger-iroha-ed25519")
+ (version "2.0.2")
+ (home-page "https://github.com/hyperledger/iroha-ed25519")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0kr1zwah8mhnpfrpk3h6hdafyqdl3ixhs7czdfscqv6vxqfiabc4"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("googletest" ,googletest)))
+ (arguments
+ `(#:tests? #f ; Tests don't build because CMake cannot find GTest main.
+ #:configure-flags '("-DHUNTER_ENABLED=OFF"
+ "-DBUILD=SHARED"
+ ;; TODO: x86_64 should use amd64-64-24k-pic but it
+ ;; fails to link when built as a shared library.
+ "-DEDIMPL=ref10"
+ "-DHASH=sha3_brainhub")))
+ (synopsis "Ed25519 digital signature algorithm")
+ (description "This repository aims to provide modularized implementation
+of the Ed25519 digital signature algorithm which is is described in
+RFC8032 (@url{https://tools.ietf.org/html/rfc8032}).
+
+Originally Ed25519 consists of three modules:
+
+@itemize
+@item digital signature algorithm itself
+@item SHA512 hash function
+@item random number generator, to generate keypairs
+@end itemize
+
+This project offers at least two different C implementations for every
+module. Every implementation can be replaced with another one at
+link-time. New implementations can be added as well.")
+ (license asl2.0)))