summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Wilson <david@daviwil.com>2019-11-11 06:54:59 -0800
committerLudovic Courtès <ludo@gnu.org>2019-11-13 23:26:36 +0100
commit35338b50011cdaf15f0b211c478bb321cc714b6e (patch)
tree6104c43ca7256f254bc0c79b63e52ef20ea7ace3
parentb057921b17b573a609e68a38b07de4849ba7c8f2 (diff)
downloadpatches-35338b50011cdaf15f0b211c478bb321cc714b6e.tar
patches-35338b50011cdaf15f0b211c478bb321cc714b6e.tar.gz
gnu: Add emacs-spacegray-theme.
* gnu/packages/emacs-xyz.scm (emacs-spacegray-theme) New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f74dbeed3d..187b38716e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -56,6 +56,7 @@
;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2019 Stephen Webber <montokapro@gmail.com>
;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4878,6 +4879,30 @@ is to keep colors easily distinguishable, contrast enough and still pleasant
for the eyes.")
(license license:expat))) ; MIT license
+(define-public emacs-spacegray-theme
+ (let ((commit "9826265c2bceb2ebc1c5e16a45021da0253ace97")
+ (revision "0"))
+ (package
+ (name "emacs-spacegray-theme")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bruce/emacs-spacegray-theme.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0aplwmm17ypbns5blc4rf5rr6dasj0zp5ibykpfl43fh4bd8z89n"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bruce/emacs-spacegray-theme")
+ (synopsis "Port of Sublime Text's Spacegray theme for Emacs")
+ (description
+ "@code{spacegray-theme} is an Emacs port of the Spacegray theme from
+Sublime Text. It features a dark blue/gray background and soft blue, green,
+orange and red as accent colors.")
+ (license license:expat)))) ; MIT license
+
(define-public emacs-2048-game
(package
(name "emacs-2048-game")