summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-03-16 10:12:47 -0500
committerEric Bavier <bavier@member.fsf.org>2016-05-12 19:04:31 +0000
commit0573a923def01e54bf104e0015ade44ab42f694f (patch)
tree43017c50ea559477064a01570e11de5127775a64
parentf6292baf922da363351066a7d280722068b246e4 (diff)
downloadpatches-0573a923def01e54bf104e0015ade44ab42f694f.tar
patches-0573a923def01e54bf104e0015ade44ab42f694f.tar.gz
gnu: Move asciidoc and doxygen to new module.
* gnu/packages/asciidoc.scm (asciidoc): Move this... * gnu/packages/doxygen.scm (doxygen): ...and this... * gnu/packages/documentation.scm: ...to here. New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add accordingly.
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/asciidoc.scm52
-rw-r--r--gnu/packages/documentation.scm (renamed from gnu/packages/doxygen.scm)36
3 files changed, 34 insertions, 57 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 871174b46f..8012fa32b3 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -40,7 +40,6 @@ GNU_SYSTEM_MODULES = \
gnu/packages/anthy.scm \
gnu/packages/apl.scm \
gnu/packages/apr.scm \
- gnu/packages/asciidoc.scm \
gnu/packages/aspell.scm \
gnu/packages/attr.scm \
gnu/packages/audacity.scm \
@@ -98,7 +97,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/dns.scm \
gnu/packages/docbook.scm \
gnu/packages/docker.scm \
- gnu/packages/doxygen.scm \
+ gnu/packages/documentation.scm \
gnu/packages/dunst.scm \
gnu/packages/dvtm.scm \
gnu/packages/ebook.scm \
diff --git a/gnu/packages/asciidoc.scm b/gnu/packages/asciidoc.scm
deleted file mode 100644
index 5bc5cfa7f9..0000000000
--- a/gnu/packages/asciidoc.scm
+++ /dev/null
@@ -1,52 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages asciidoc)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (gnu packages python)
- #:use-module (guix build-system gnu)
- #:autoload (gnu packages zip) (unzip))
-
-(define-public asciidoc
- (package
- (name "asciidoc")
- (version "8.6.9")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/asciidoc/asciidoc-"
- version ".tar.gz"))
- (sha256
- (base32
- "1w71nk527lq504njmaf0vzr93pgahkgzzxzglrq6bay8cw2rvnvq"))))
- (build-system gnu-build-system)
- (arguments '(#:tests? #f)) ; no 'check' target
- (inputs `(("python" ,python-2)))
- (home-page "http://www.methods.co.nz/asciidoc/")
- (synopsis "Text-based document generation system")
- (description
- "AsciiDoc is a text document format for writing notes, documentation,
-articles, books, ebooks, slideshows, web pages, man pages and blogs.
-AsciiDoc files can be translated to many formats including HTML, PDF,
-EPUB, man page.
-
-AsciiDoc is highly configurable: both the AsciiDoc source file syntax and
-the backend output markups (which can be almost any type of SGML/XML
-markup) can be customized and extended by the user.")
- (license gpl2+)))
diff --git a/gnu/packages/doxygen.scm b/gnu/packages/documentation.scm
index 8e4cbb936c..567669a3b6 100644
--- a/gnu/packages/doxygen.scm
+++ b/gnu/packages/documentation.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2016 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
@@ -16,18 +17,47 @@
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-(define-module (gnu packages doxygen)
- #:use-module ((guix licenses) #:select (gpl3+))
+(define-module (gnu packages documentation)
+ #:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
#:use-module (gnu packages)
+ #:use-module (gnu packages python)
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages perl)
#:use-module (gnu packages xml)
- #:use-module (gnu packages python))
+ #:autoload (gnu packages zip) (unzip))
+
+(define-public asciidoc
+ (package
+ (name "asciidoc")
+ (version "8.6.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/asciidoc/asciidoc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1w71nk527lq504njmaf0vzr93pgahkgzzxzglrq6bay8cw2rvnvq"))))
+ (build-system gnu-build-system)
+ (arguments '(#:tests? #f)) ; no 'check' target
+ (inputs `(("python" ,python-2)))
+ (home-page "http://www.methods.co.nz/asciidoc/")
+ (synopsis "Text-based document generation system")
+ (description
+ "AsciiDoc is a text document format for writing notes, documentation,
+articles, books, ebooks, slideshows, web pages, man pages and blogs.
+AsciiDoc files can be translated to many formats including HTML, PDF,
+EPUB, man page.
+
+AsciiDoc is highly configurable: both the AsciiDoc source file syntax and
+the backend output markups (which can be almost any type of SGML/XML
+markup) can be customized and extended by the user.")
+ (license gpl2+)))
(define-public doxygen
(package