summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-12 10:25:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-12 10:25:42 +0200
commitd8ba1135eb3cc0a01f84675bec4979d58301f8f5 (patch)
tree763ad0eff325a12807d044c95aff8453409d8538
parentbf8ee1c5046c7011d641e10277984c9bb7dc7c2f (diff)
downloadpatches-d8ba1135eb3cc0a01f84675bec4979d58301f8f5.tar
patches-d8ba1135eb3cc0a01f84675bec4979d58301f8f5.tar.gz
gnu: python2-ipython: Fix build.
* gnu/packages/python-xyz.scm (python2-ipython)[arguments]: Adjust skipped tests.
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8e8790b29a..8c3c0d2d69 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5743,9 +5743,9 @@ computing.")
(add-before 'check 'delete-broken-tests
(lambda* (#:key inputs #:allow-other-keys)
;; These tests throw errors for unknown reasons.
+ (delete-file "IPython/core/tests/test_displayhook.py")
+ (delete-file "IPython/core/tests/test_magic_terminal.py")
(delete-file "IPython/core/tests/test_profile.py")
- (delete-file "IPython/core/tests/test_interactiveshell.py")
- (delete-file "IPython/core/tests/test_magic.py")
#t)))))
(home-page "https://ipython.org")
(synopsis "IPython is a tool for interactive computing in Python")