summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-09-05 18:08:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-09-06 15:46:00 +0300
commitc891c7f174eb1942e75324f494aade8da1c04f36 (patch)
tree39b670ca496eaf36e8fdfb472eeb0ee7ed8492c6
parentf0074113086c32ebb31f49cf01a2fd4740d01999 (diff)
downloadpatches-c891c7f174eb1942e75324f494aade8da1c04f36.tar
patches-c891c7f174eb1942e75324f494aade8da1c04f36.tar.gz
gnu: Add rust-cargon.
* gnu/packages/crates-io.scm (rust-cargon): New variable.
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 183291e737..35453124ef 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -210,6 +210,29 @@ behave like a set of bitflags.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-cargon
+ (package
+ (name "rust-cargon")
+ (version "0.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cargon" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1cszlab7jk736p0lb50ag4l9nv72m7j41bwrmygl0lr4iz0350w2"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-gcc" ,rust-gcc))))
+ (home-page "https://github.com/bryant/argon2rs")
+ (synopsis "Thin wrapper around the Argon2 C library")
+ (description
+ "This package provides a thin wrapper around the Argon2 C library. It is
+used in argon2rs' bench suite.")
+ (license license:wtfpl2)))
+
(define-public rust-cblas-sys
(package
(name "rust-cblas-sys")