summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmar Singh <nly@disroot.org>2020-03-12 16:25:33 +0530
committerMathieu Othacehe <m.othacehe@gmail.com>2020-03-12 15:52:41 +0100
commitbe78906592c761aa2a67e979074561e459efdcac (patch)
tree90e8c6d24ea8dc3616e4bf35acecf8022d17cb85
parent0c08e4bfa1cb760a8f103b5223f0220617a93025 (diff)
downloadpatches-be78906592c761aa2a67e979074561e459efdcac.tar
patches-be78906592c761aa2a67e979074561e459efdcac.tar.gz
* gnu/packages/guile-xyz.scm (guile-torrent): New variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/guile-xyz.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index b71b0178d6..9f8173657e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 swedebugia <swedebugia@riseup.net>
-;;; Copyright © 2019 Amar Singh <nly@disroot.org>
+;;; Copyright © 2019, 2020 Amar Singh <nly@disroot.org>
;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
;;;
;;; This file is part of GNU Guix.
@@ -3144,3 +3144,33 @@ models and also supports a rich set of boolean query operators.")
(inputs
`(("guile" ,guile-next)
,@(alist-delete "guile" (package-inputs guile-xapian))))))
+
+(define-public guile-torrent
+ (package
+ (name "guile-torrent")
+ (version "0.1.3")
+ (source (origin (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/o-nly/torrent.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yiagi55ncq1x7s9n7salzywjm4l96y3n7y3s47a9anvz87mrmim"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("guile" ,guile-2.2)
+ ("texinfo" ,texinfo)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("guile-gcrypt" ,guile-gcrypt)))
+ (home-page "https://github.com/o-nly/torrent")
+ (synopsis "Torrent library for GNU Guile")
+ (description "This package provides facilities for working with
+@code{.torrent} or metainfo files. Implements a bencode reader and writer
+according to Bitorrent BEP003.")
+ (license license:gpl3+)))