summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-08-31 22:46:52 +0200
committerLudovic Courtès <ludo@gnu.org>2013-08-31 23:02:18 +0200
commitb48d21b24634399b41f6d5144691b58c159d72e2 (patch)
tree4bdf6a666d6e3c7ebfe053e0395447c2d9f89b11
parent89bf140b10ae24755bf9d2b789b945d29ff11937 (diff)
downloadpatches-b48d21b24634399b41f6d5144691b58c159d72e2.tar
patches-b48d21b24634399b41f6d5144691b58c159d72e2.tar.gz
gnu: linux-initrd: Make device nodes for QEMU's hard disk.
* gnu/packages/linux-initrd.scm (qemu-initrd): Make /dev/vda*.
-rw-r--r--gnu/packages/linux-initrd.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/linux-initrd.scm b/gnu/packages/linux-initrd.scm
index f1e488ad69..17f42652e8 100644
--- a/gnu/packages/linux-initrd.scm
+++ b/gnu/packages/linux-initrd.scm
@@ -270,6 +270,11 @@ the Linux kernel.")
(unless (configure-qemu-networking)
(display "network interface is DOWN\n"))
+ ;; Make the device nodes for QEMU's hard disk and partitions.
+ (mknod "/dev/vda" 'block-special #o644 (device-number 8 0))
+ (mknod "/dev/vda1" 'block-special #o644 (device-number 8 1))
+ (mknod "/dev/vda2" 'block-special #o644 (device-number 8 2))
+
;; Prepare the real root file system under /root.
(unless (file-exists? "/root")
(mkdir "/root"))