summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-03-11 23:53:19 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-12 11:52:21 +0100
commita20cfe71e9cd9450e9cfbe9e4bc478a0c726a2af (patch)
treed5e6548bfc868d373657991186c71fb3d57a7e6a
parentec73c90ee35a404b04b030b260c386011c0cbe94 (diff)
downloadpatches-a20cfe71e9cd9450e9cfbe9e4bc478a0c726a2af.tar
patches-a20cfe71e9cd9450e9cfbe9e4bc478a0c726a2af.tar.gz
gnu: guile-next: Enable JIT on ARMv7.
JIT support on ARMv7 is fixed by "guile-3.0-crash.patch". * gnu/packages/guile.scm (guile-3.0)[arguments]: Remove.
-rw-r--r--gnu/packages/guile.scm9
1 files changed, 0 insertions, 9 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 1d9d93d774..80ac9ea706 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -303,15 +303,6 @@ without requiring the source code to be rewritten.")
(patches
(append (search-patches "guile-3.0-crash.patch")
(origin-patches (package-source guile-2.2))))))
-
- (arguments
- (substitute-keyword-arguments (package-arguments guile-2.2)
- ;; XXX: On ARMv7, work around <https://bugs.gnu.org/39208> by disabling
- ;; JIT.
- ((#:configure-flags flags '())
- (if (target-arm32?)
- `(cons "--disable-jit" ,flags)
- flags))))
(native-search-paths
(list (search-path-specification
(variable "GUILE_LOAD_PATH")