summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-10-23 08:25:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-24 00:04:14 +0200
commit9e1c358139d0029e8a0c6f4be9ce979976bfa07c (patch)
tree94732dbf864db18ce753c0898d35ab33512af710
parent3b6958021df2d26a56b3ae78cff9f08cd79f06fc (diff)
downloadpatches-9e1c358139d0029e8a0c6f4be9ce979976bfa07c.tar
patches-9e1c358139d0029e8a0c6f4be9ce979976bfa07c.tar.gz
gnu: Add perl-tree-xpathengine.
* gnu/packages/xml.scm (perl-tree-xpathengine): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/xml.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index add9311a82..f8aea6f90d 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1292,3 +1292,24 @@ much of the XPath features can be used. A module implementing all of the DOM
should be able to use this module very easily (you might need to add the
@code{cmp} method on nodes in order to get ordered result sets).")
(license license:perl-license)))
+
+(define-public perl-tree-xpathengine
+ (package
+ (name "perl-tree-xpathengine")
+ (version "0.05")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MI/MIROD/"
+ "Tree-XPathEngine-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vbbw8wxm79r3xbra8narw1dqvm34510q67wbmg2zmj6zd1k06r9"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Tree-XPathEngine/")
+ (synopsis "Re-usable XPath engine")
+ (description
+ "This module provides an XPath engine, that can be re-used by other
+module/classes that implement trees. It is designed to be compatible with
+@code{Class::XPath}, ie it passes its tests if you replace @code{Class::XPath}
+by @code{Tree::XPathEngine}.")
+ (license license:perl-license)))