summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-14 21:12:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-15 00:32:15 +0200
commit409dec3f29084c8c8caadfe5852e9f4b7f3546f9 (patch)
treed1a3410ad7c28bcd586b490ed3916eca18598933
parentd0b025ea69ac3b4fcc8fdf5bc1ea3a962eb19750 (diff)
downloadpatches-409dec3f29084c8c8caadfe5852e9f4b7f3546f9.tar
patches-409dec3f29084c8c8caadfe5852e9f4b7f3546f9.tar.gz
gnu: aubio: Update to 0.4.6.
* gnu/packages/audio.scm (aubio): Update to 0.4.6. [arguments]: Set reflexive RUNPATH.
-rw-r--r--gnu/packages/audio.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 06ea6645c4..02af258348 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -145,24 +145,26 @@ Filter) modules follow the convention of 1V / Octave.")
(define-public aubio
(package
(name "aubio")
- (version "0.4.1")
+ (version "0.4.6")
(source (origin
(method url-fetch)
(uri (string-append
"http://aubio.org/pub/aubio-" version ".tar.bz2"))
(sha256
(base32
- "15f6nf76y7iyl2kl4ny7ky0zpxfxr8j3902afvd6ydnnkh5dzmr5"))))
+ "1yvwskahx1bf3x2fvi6cwah1ay11iarh79fjlqz8s887y3hkpixx"))))
(build-system waf-build-system)
(arguments
`(#:tests? #f ; no check target
#:configure-flags
- '("--enable-fftw3f"
- "--enable-jack"
- "--enable-sndfile"
- "--enable-samplerate"
- ;; enable compilation with avcodec once available
- "--disable-avcodec")
+ (list
+ (string-append "LDFLAGS=-Wl,-rpath=" (assoc-ref %outputs "out") "/lib")
+ "--enable-fftw3f"
+ "--enable-jack"
+ "--enable-sndfile"
+ "--enable-samplerate"
+ ;; TODO: enable compilation with avcodec once available.
+ "--disable-avcodec")
#:python ,python-2))
(inputs
`(("jack" ,jack-1)