summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-09-26 05:01:26 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-09-26 05:24:30 +0200
commit3f3d712cc525d65c184cea4c2048a62a4ec87c73 (patch)
tree8e7797b549a5415f1466dfa5ed918f1d636519ad
parentd94ec407585dc4d34ec80a28567f98205c4f24c2 (diff)
downloadpatches-3f3d712cc525d65c184cea4c2048a62a4ec87c73.tar
patches-3f3d712cc525d65c184cea4c2048a62a4ec87c73.tar.gz
gnu: beets: Update to 1.4.9.
* gnu/packages/music.scm (beets): Update to 1.4.9. [source]: Remove patch. [arguments]: Remove more Python 3.7 compatibility fixes. * gnu/packages/patches/beets-python-3.7-fix.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/music.scm11
-rw-r--r--gnu/packages/patches/beets-python-3.7-fix.patch57
3 files changed, 2 insertions, 67 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 919e836b8c..49dc4e7b97 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -711,7 +711,6 @@ dist_patch_DATA = \
%D%/packages/patches/bash-completion-directories.patch \
%D%/packages/patches/bastet-change-source-of-unordered_set.patch \
%D%/packages/patches/bazaar-CVE-2017-14176.patch \
- %D%/packages/patches/beets-python-3.7-fix.patch \
%D%/packages/patches/beignet-correct-file-names.patch \
%D%/packages/patches/benchmark-unbundle-googletest.patch \
%D%/packages/patches/biber-fix-encoding-write.patch \
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index b28b375067..508f2ea3bf 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2813,14 +2813,13 @@ Songs can be searched by artist, name or even by a part of the song text.")
(define-public beets
(package
(name "beets")
- (version "1.4.7")
+ (version "1.4.9")
(source (origin
(method url-fetch)
(uri (pypi-uri "beets" version))
- (patches (search-patches "beets-python-3.7-fix.patch"))
(sha256
(base32
- "0w3gz69s9gf5ih69d4sddgh7ndj7658m621bp742zldvjakdncrs"))))
+ "0m40rjimvfgy1dv04p8f8d5dvi2855v4ix99a9xr900cmcn476yj"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -2829,12 +2828,6 @@ Songs can be searched by artist, name or even by a part of the song text.")
(lambda _
(setenv "HOME" (string-append (getcwd) "/tmp"))
#t))
- (add-after 'unpack 'make-python3.7-compatible
- (lambda _
- ;; See <https://github.com/beetbox/beets/issues/2978>.
- (substitute* "beets/autotag/hooks.py"
- (("re\\._pattern_type") "re.Pattern"))
- #t))
(replace 'check
(lambda _
(invoke "nosetests" "-v"))))))
diff --git a/gnu/packages/patches/beets-python-3.7-fix.patch b/gnu/packages/patches/beets-python-3.7-fix.patch
deleted file mode 100644
index 43707cd9d0..0000000000
--- a/gnu/packages/patches/beets-python-3.7-fix.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-Fix compatibility issue with Python 3.7:
-
-https://github.com/beetbox/beets/issues/2978
-
-Patch copied from upstream source repository:
-
-https://github.com/beetbox/beets/commit/15d44f02a391764da1ce1f239caef819f08beed8
-
-From 15d44f02a391764da1ce1f239caef819f08beed8 Mon Sep 17 00:00:00 2001
-From: Adrian Sampson <adrian@radbox.org>
-Date: Sun, 22 Jul 2018 12:34:19 -0400
-Subject: [PATCH] Fix Python 3.7 compatibility (#2978)
-
----
- beets/autotag/hooks.py | 8 +++++++-
- docs/changelog.rst | 2 ++
- 2 files changed, 9 insertions(+), 1 deletion(-)
-
-diff --git a/beets/autotag/hooks.py b/beets/autotag/hooks.py
-index 3615a9333..1c62a54c5 100644
---- a/beets/autotag/hooks.py
-+++ b/beets/autotag/hooks.py
-@@ -31,6 +31,12 @@
-
- log = logging.getLogger('beets')
-
-+# The name of the type for patterns in re changed in Python 3.7.
-+try:
-+ Pattern = re._pattern_type
-+except AttributeError:
-+ Pattern = re.Pattern
-+
-
- # Classes used to represent candidate options.
-
-@@ -433,7 +439,7 @@ def _eq(self, value1, value2):
- be a compiled regular expression, in which case it will be
- matched against `value2`.
- """
-- if isinstance(value1, re._pattern_type):
-+ if isinstance(value1, Pattern):
- return bool(value1.match(value2))
- return value1 == value2
-
-#diff --git a/docs/changelog.rst b/docs/changelog.rst
-#index be6de2904..d487f31f5 100644
-#--- a/docs/changelog.rst
-#+++ b/docs/changelog.rst
-#@@ -19,6 +19,8 @@ New features:
-#
-# Fixes:
-#
-#+* Fix compatibility Python 3.7 and its change to a name in the ``re`` module.
-#+ :bug:`2978`
-# * R128 normalization tags are now properly deleted from files when the values
-# are missing.
-# Thanks to :user:`autrimpo`.