summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>2020-03-11 21:50:14 -0600
committerGuix Patches Tester <>2020-03-12 13:49:16 +0000
commit0c6b0052bd720b627fe92d576b09eacd7352e446 (patch)
tree49605e7cc07a789ea61d3499012274149fbda5d5
parent04ff192ec4c815cf9a2e71fc0c796a6c6ce19429 (diff)
downloadpatches-series-3149.tar
patches-series-3149.tar.gz
gnu: Add widelands.series-3149
* gnu/packages/games.scm (widelands): New variable.
-rw-r--r--gnu/packages/games.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 9b4ff4df9a..068e48bac6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -46,6 +46,7 @@
;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10157,3 +10158,48 @@ best human chess grandmasters. It can be used with UCI-compatible GUIs like
ChessX.")
(home-page "https://stockfishchess.org/")
(license license:gpl3+)))
+
+(define-public widelands
+ (let ((commit "d9513d413f2558f9ef6f033a7685bf9881fbdbb3")
+ (revision "1"))
+ (package
+ (name "widelands")
+ (version (git-version "20" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/widelands/widelands.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rsm25kb60xfvib8xk2hcqbppcyjgaiax1rpxxn6vlwrx68nndqp"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:configure-flags
+ (let* ((out (assoc-ref %outputs "out"))
+ (share (string-append out "/share")))
+ (list "-DCMAKE_BUILD_TYPE=Release"
+ (string-append "-DCMAKE_INSTALL_PREFIX=" out "/bin")
+ (string-append "-DWL_INSTALL_BASEDIR=" share "/widelands")
+ (string-append "-DWL_INSTALL_DATADIR=" share "/widelands")
+ "-DOPTION_BUILD_WEBSITE_TOOLS=OFF"))))
+ (inputs
+ `(("sdl" ,(sdl-union (list sdl2
+ sdl2-image
+ sdl2-mixer
+ sdl2-ttf)))
+ ("gettext" ,gettext-minimal)
+ ("icu4c" ,icu4c)
+ ("libpng" ,libpng)
+ ("zlib" ,zlib)
+ ("boost" ,boost)
+ ("python" ,python)
+ ("glew" ,glew)))
+ (synopsis "Real-time strategy game")
+ (description
+ "Widelands is a free, open source real-time strategy game with
+ singleplayer campaigns and a multiplayer mode. The game was inspired
+ by Settlers II but has significantly more variety and depth to it. ")
+ (home-page "https://www.widelands.org/")
+ (license license:gpl2+))))