summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-11 19:02:46 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-11 19:02:46 +0100
commitf8cbe98e65c9cabcad420f98c855aa20ac1a25a0 (patch)
treea79442c5baaa45bd50bd36c40e2ec548b3478270
parent805ac43c94da049284bdc9981a897a89770cf86b (diff)
downloadpatches-f8cbe98e65c9cabcad420f98c855aa20ac1a25a0.tar
patches-f8cbe98e65c9cabcad420f98c855aa20ac1a25a0.tar.gz
gnu: isc-dhcp: Fix cross-compilation.
* gnu/packages/admin.scm (isc-dhcp)[arguments]: Set BUILD_CC in 'fix-bind-cross-compilation' phase. While at it, make the phase conditional on %CURRENT-TARGET-SYSTEM.
-rw-r--r--gnu/packages/admin.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 51a74302e4..0f27e6370b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -18,7 +18,7 @@
;;; Copyright © 2017 Ben Sturmfels <ben@sturm.com.au>
;;; Copyright © 2017 Ethan R. Jones <doubleplusgood23@gmail.com>
;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
-;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2018, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018, 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
@@ -809,12 +809,17 @@ connection alive.")
(("^RELEASEVER=.*")
(format #f "RELEASEVER=~a\n" ,bind-release-version)))
#t))
- (add-before 'configure 'fix-bind-cross-compilation
- (lambda _
- (substitute* "configure"
- (("--host=\\$host")
- "--host=$host_alias"))
- #t))
+ ,@(if (%current-target-system)
+ '((add-before 'configure 'fix-bind-cross-compilation
+ (lambda _
+ (substitute* "configure"
+ (("--host=\\$host")
+ "--host=$host_alias"))
+ ;; BIND needs a native compiler because the DHCP
+ ;; build system uses the built 'gen' executable.
+ (setenv "BUILD_CC" "gcc")
+ #t)))
+ '())
(add-after 'configure 'post-configure
(lambda* (#:key outputs #:allow-other-keys)
;; Point to the right client script, which will be