summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-03-11 19:33:25 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-03-11 19:33:25 +0100
commitf7f67495ba0c2f08b0372e925725b4d196e037b6 (patch)
tree8aec4c86635a0d9d81b402e6dec4b69020ada5cb
parentf8cbe98e65c9cabcad420f98c855aa20ac1a25a0 (diff)
downloadpatches-f7f67495ba0c2f08b0372e925725b4d196e037b6.tar
patches-f7f67495ba0c2f08b0372e925725b4d196e037b6.tar.gz
gnu: spatialite-gui: Fix GUI not showing up.
* gnu/packages/geo.scm (spatialite-gui)[arguments]: Add 'fix-gui' phase.
-rw-r--r--gnu/packages/geo.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 1346ebeb5f..05d177c3b1 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -561,6 +561,14 @@ development.")
("sqlite" ,sqlite)
("wxwidgets" ,wxwidgets-2)
("zlib" ,zlib)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'fix-gui
+ (lambda _
+ ;; Fix for the GUI not showing up.
+ (substitute* "Main.cpp"
+ (("Hide\\(\\);") ""))
+ #t)))))
(synopsis "Graphical user interface for SpatiaLite")
(description "Spatialite-gui provides a visual interface for viewing and
maintaining a spatialite database. You can easily see the structure of the