summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-03-10 21:57:35 +0000
committerDanny Milosavljevic <dannym@scratchpost.org>2020-03-11 16:12:45 +0100
commite05ce17dbc96f5cc9edecccf4587867a16b1489a (patch)
tree946219def807e54d7cc842b2b74f911ec3d38ebd
parentd9a2a255f9918c07f89dbe9ae62ba063fa70ffef (diff)
downloadpatches-e05ce17dbc96f5cc9edecccf4587867a16b1489a.tar
patches-e05ce17dbc96f5cc9edecccf4587867a16b1489a.tar.gz
gnu: Add phodav.
* gnu/packages/gnome.scm (phodav): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/gnome.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 05d3125bd8..86d0b8881c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -246,6 +246,35 @@ Desktop. It is designed to be as simple as possible and has some unique
features to enable users to create their discs easily and quickly.")
(license license:gpl2+)))
+(define-public phodav
+ (package
+ (name "phodav")
+ (version "2.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1hxq8c5qfah3w7mxcyy3yhzdgswplll31a69p5mqdl04bsvw5pbx"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk-doc" ,gtk-doc)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("avahi" ,avahi)
+ ("libgudev" ,libgudev)
+ ("libsoup" ,libsoup)))
+ (synopsis "WebDav server implementation using libsoup")
+ (description "PhoDav was initially developed as a file-sharing mechanism for Spice,
+but it is generic enough to be reused in other projects,
+in particular in the GNOME desktop.")
+ (home-page "https://wiki.gnome.org/phodav")
+ (license license:lgpl2.1+)))
+
(define-public gnome-color-manager
(package
(name "gnome-color-manager")